I have the same problem now, like so many others since years...

Here is what I've done:

I've buied two brand new Cherry MX Board 3.0 s keyboards. Both I've plugged directly to Ubuntu 20.04 - one at work, one at home. Both have worked very well with very good performance.

Yesterday, I've plugged the one at home to a MS Surface 3 with Windows 10. After that, I've had the same Problem like so many Ubuntu users for years and years and years.... the letters from my keyboard are coming very delayed on my screen on my Ubuntu PC.

I’ve plugged it on my iMac - absolutely no problem.
I’ve plugged it back on Windows 10 - absolutely no problem.
I‘ve plugged it on another Ubuntu PC with Groovy Gorilla - keyboard lag.
I’ve plugged it back on my Ubuntu 20.04 - keyboard lag.
I’ve switched my Ubuntu 20.04 while login to the Wayland Ubuntu - absolutely no problem.
Installed Kali Linux - absolutely no problem.
Installed Pop_OS (Gnome) - keyboard lag.
Installed Debian 10 (Gnome 3.30.2) - absolutely no problem.

There is nothing wrong with any preferences in Ubuntu! In Bios, typing the encription key or the login password the keyboard works very well in high performance. On this second, I get in to the regular Ubuntu OS, the keyboard lagging problem is there...

So for all the years, there is no solution?????

  • 1
    As I wrote, there is nothing wrong with any system preferences in Ubuntu. „Slow Keys“ was the first thing I‘ve checked.
    – Manny
    Nov 21, 2020 at 7:40
  • then I am sorry for the wrong guess. What is the major difference between your question and among others 'keyboard lag' in Ubuntu then? Nov 21, 2020 at 18:21

1 Answer 1


......for CHERRY MX BOARD 3.0S

The problem has come while the Keyboard was connected to Windows 10 with the CHERRY gaming software. I don't know why this connection was a problem only for Ubuntu, but a reset to the keyboards original delivery state has help and the keyboard works very fine again.

OS: Ubuntu 20.04
Resetting CHERRY MX BOARD 3.0S to its original delivery state:
Press and hold the FN button and pause button for 5 seconds. The original delivery state is restored.

  • also works for ubuntu 18.04
    – Tim He
    Feb 9, 2022 at 1:55
  • Thanks! Solved my problem! This might be related to a to high USB Polling value set in the gaming software.
    – TekTimmy
    Aug 19, 2022 at 13:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .