1

Manjaro, Kubuntu 20.10 and Ubuntu 20.04.1 LTS all crash on me if I won't set maxcpus=1 in GRUB. Replacing quiet splash with nomodeset or changing UEFI BIOS settings to disable all Intel CPU features changes nothing.
Windows 10 runs without issues and is perfectly stable.
Available crash logs:

mce: [Hardware Error]: CPU 5: Machine Check Exception: 5 Bank 0: f600020000040150
mce: [Hardware Error]: RIP !INEXACT! 10:<fffffffffb9c7e8eb> {mwait_idle_with_hints.constprop.0+0x4b/0x90}
mce: [Hardware Error]: TSC 25d1e1e46d ADDR 7fabd0e68be3
mce: [Hardware Error]: PROCESSOR 0:506e3 TIME 1605392958 SOCKET 0 APIC 3 microcode dcd64.deb: mismatch OK4.deb
mce: [Hardware Error]: Run the above through 'mcelog --ascii'
mce: [Hardware Error]: CPU 1: Machine Check Exception: 5 Bank 0: f60001c000040150
mce: [Hardware Error]: RIP !INEXACT! 33:<0007fadb0e68bea>
mce: [Hardware Error]: TSC 25d1e1dc9 ADDR 1605392958
mce: [Hardware Error]: PROCESSOR 0:506e3 TIME 1605392958 SOCKET 0 APIC 2 microcode dc
mce: [Hardware Error]: Run the above through 'mcelog --ascii'
mce: [Hardware Error]: Machine check: Processor context corrupt
Kernel panic - not syncing: Fatal machine check
Kernel Offset: 0x38600000 from 0xfffffffff81000000 (relocation range: 0xfffffffff8000000-0xffffffffbffffff)
Rebooting in 30 seconds..

CPU: i7-6700K
GPU: GTX-1070
Motherboard: ASUS Z170-P
UEFI BIOS: 3805 x64 05/16/2018 (latest at the time of writting)
ME Firmware Version: 11.8.55.3510 (latest at the time of writting)
I'd like to know if it would be possible to use more than 1/8 vCPU (4 physical cores x 2 virtual cores each).

0

This looks like a hardware failure of either your CPU or your RAM. Since you've tried different distros, it seems pretty obvious, that your problem is described here

More information about "MCE" errors...

2
  • Even considering it's once again perfectly stable for several hours long gaming on Windows 10 (after reverting update)? Could this feature of freezing them crashing on supposed hardware problem be turned off? I can install and use Linux with 1 core after all (already work 8+ hours a day since Monday). Also, dedicated Intel testing tool found no issues with CPU.
    – Hekkaryk
    Nov 19 '20 at 23:52
  • Well, then there's is only one idea left. Once I tried to install Linux on a laptop but the soundcard did not work. It worked on windows, but not on Linux. Obviously the bios was faulty, an the windows version altered the DSDT table, so it worked. Here is a PDF that indicates that only Fedora 23 (which is quit old) will work with it. So it might be an incompatiblity of you motherboard. Maybe someone has written a driver (or patched the DSDT table).
    – kanehekili
    Nov 20 '20 at 15:36
0

Following try-and-failure boot option testing I've come to an forum post at https://ubuntuforums.org/showthread.php?t=1084622 that suggested following boot options that I've tested with which Kubuntu 20.10 boots, uses all CPUs and does not crash by itself within first 3h 45m+:

noapic pci=assign-busses apicmaintimer idle=poll reboot=cold,hard

uname -rsv

Linux 5.8.0-29-generic #31-Ubuntu SMP Fri Nov 6 12:37:59 UTC 2020

Kubuntu binary being used:

vmlinuz-5.8.0-29-generic

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.