I've installed nVidia driver successfully but I want to go back to Nouveau driver and eliminate any xorg.conf file created by nVidia config tools.

What is the proper way to do it? (not ending up with no driver at all, or no X server)


3 Answers 3


To reconfigure xorg.conf. Move your current /etc/X11/xorg.conf. If things go wrong you might need it later again:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.BACKUP

The following steps will install the nouveau-driver on configure the xserver accordingly:

sudo apt-get install nouveau-firmware
sudo dpkg-reconfigure xserver-xorg

Go following the screen steps, answering the wizard questions and you should able to restore or reconfigure to previous Nouveau state.

  • 1
    you might want to ensure you've got the right dependencies: $ sudo apt-get install nouveau-firmware
    – carl crott
    Nov 21, 2012 at 16:51
  • sudo dpkg-reconfigure xserver-xorg => I get a popup that says some ubuntu program has crashed. If I try again, nothing happens
    – matteo
    Oct 13, 2013 at 22:46
  • 2
    I just have xorg installed and not xserver-xorg, (I use xserver-xorg-lts-utopic from 14.04 trusty). Just the first step worked for me.
    – pd12
    Nov 18, 2015 at 3:20

If you installed using the recommended procedure through System -> Administration -> Hardware Drivers or Additional Drivers, simply go back there and click the driver in use to hilite it, click "Remove". this will safely remove the nVidia driver in use and allow Nouveau to take it's place. You can, if desired, remove the /etc/X11/xorg.conf manually before restarting the computer.

The driver in use is normally the one with the green button on the left.

  • 5
    What if the GUI refuses to start? What is the CLI command to do this? (on my GT 425M, only the console was accessible after a reboot with the properitary drivers from )
    – Lekensteyn
    Jan 6, 2011 at 13:49
  • If that happens, boot to the recovery menu, and remove or rename /etc/X11/xorg.conf. This file does prevent the gui from starting on some systems. Jan 16, 2011 at 18:46

Quick answer: remove xorg.conf (see below) and then disable the nvidia drivers from additional drivers menu once the gui is available.

Long answer: I did get nvidia and dual screen to work, but spent two days trying... here's my knowledge. Single screen was always the easy chore. Stock install of 11.10 without Nvidia works but not for dual screen. Countless issues but one thing to document is whether 11.10 nouveau video driver is being used or nvidia. After an upgrade to 11.10 the nvidia blows up. To get single screen to work hit ctrl-alt-f2 and login to shell. If you know it's nvidia plugins still being used try: (make backup first)

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak     
sudo rm /etc/X11/xorg.conf
sudo reboot

But going back and forth can mess things up so sometimes make sure:

  1. Ubuntu nouveau uses ~/.config/monitors.xml If nvidia is enabled instead, make sure to name this .bak so it's not used

  2. Nividia uses xorg.conf If nouveau/stock driver is used name this .bak

Otherwise things might boot to hung shell. Sometimes nvidia screws up xorg.conf itself (pre 11.10) and the file should be deleted.

Long story short to get dual monitors to work I found that only nvidia 173-updates drivers from the settings>Harware>additional drivers menu would work. The nvidia console itself is still broken but you can manually add :

Option      "twinview"

to the screen section of xorg.conf and after reboot it works. (theres other posts about this) To get an initial xorg.conf run

sudo nvidia-xconfig

The ppx-swat/ nividia current stuff did not work even after adding the twinview line. Stock 11.10 drivers were nice for single monitor but with dual screen make the windows super laggy, as if crashing or something. I hope this helps someone using nvidia and 11.10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .