For the past few days I've been trying to get compiz working on Ubuntu 12.04 with my NVIDIA graphics card - GeForce GT550M, but I couldn't get it to work. I've been searched for tips and tricks on how to do it but nothing has worked so far. This is the last one I tried - http://www.howtoforge.com/enabling-compiz-fusion-on-ubuntu-11.10-oneiric-ocelot.

It appears to be pretty easy but whenever I open the Additional Drivers tool, it says "no proprietary drivers are in use on this system". All the tutorials I have found include this step so none of them have worked.

I would really like to use compiz effects but I don't know what to try any more, so I could really use some help. Thanks in advance!

  • Does the default driver not provide 3D acceleration for you? – Nicolay Doytchev May 1 '12 at 13:53
  • GeForce GT550M is an Optimus card so your answer is here: askubuntu.com/questions/36930/… – user59564 May 2 '12 at 13:10
  • mark it as solved – Suhaib Aug 23 '12 at 2:43

***This approach is simpler and it allows for easier reversal.

Manual NVIDIA binary driver package install

Install the NVIDIA binary driver package manually. It will automatically blacklist the Nouveau default driver and make the kernel modules for you:

sudo apt-get install nvidia-current

Become root:

sudo -i

Then simply modify your "xorg.conf" to use it. Copy and paste the whole code snippet in the terminal where you ran "sudo -i":

echo 'Section "Screen"
        Identifier      "Default Screen"
        DefaultDepth    24

Section "Module"
        Load    "glx"

Section "Device"
        Identifier      "Default Device"
        Driver  "nvidia"
        Option  "NoLogo"        "True"
' > /etc/X11/xorg.conf

Then reboot your machine.


In case it doesn't work, you can get back to the default state by reverting the changes:

sudo rm /etc/X11/xorg.conf && sudo apt-get purge nvidia-current nvidia-settings

And of course then you need to reboot.

Afterwards you could attempt @conner_bw's suggestion as a last resort.

| improve this answer | |
  • Sorry i couldnt figure out how to reply to your questions and notes I dont know if the default driver provides 3D acceleration. All i want is for compiz effects to work and everywhere i look people are talking about drivers so i figured that is part of my problem. I tried both of your suggestions. conner_bw's i tried but it didnt stop to tell me i had no drivers installed, even though the uninstall was successfull and i added nouveau etc. to the blacklist. It just went straight to the desktop as if nothing had changed lightrush's i tried and got no errors in the process, but when i went to tes – Tim May 1 '12 at 15:24
  • Okay, let's see whether you have 3D acceleration or not. Run: "sudo apt-get install mesa-utils && glxinfo | grep direct". Paste the output here. – Nicolay Doytchev May 1 '12 at 16:27

Have you tried the downloading and manually installing drivers? Fair warning: This is a pain to maintain yourself. This is how I was able to run 10.04 LTS for several months. My NVIDIA card (a GeForce GT430) was never detected. As a last resort, this worked great. As I type my video card now fine in 12.04... But, it never worked in 10.04 no matter how much I tried until I did this.

1) Download the newest drivers here:


IMPORTANT: Keep these in a safe place in your home folder! Every time you update the kernel you will need to run the installer again. What happens is, every time Ubuntu auto updates the kernel and reboots, it complains and gets stuck. Don't panic. Simply drop to a console and run the installer again (Steps 6, 7, 8, and 9) when this happens.

2) Open module blacklist as root:

gksudo gedit /etc/modprobe.d/blacklist.conf

3) Add these lines to the bottom of the file and save:

blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

4) Uninstall any previously installed Nvidia drivers:

sudo apt-get --purge remove nvidia-*

5) Reboot your computer

6) When an error message pops up saying that Ubuntu cannot load Nvidia drivers, choose Exit to terminal (Exit to console)

6b) If it boots without error, try Ctrl+Alt+F1, login as yourself, sudo service gdm stop

7) Install drivers (change REPLACE_ME accordingly):

sudo sh NVIDIA-Linux-__REPLACE_ME__.run

8) Answer the questions in the installer, follow-through, exit.

9) Restart:

sudo shutdown -r now

Source: http://ubuntuforums.org/showthread.php?t=1467074

PS: To uninstall, if ever, it's sudo sh NVIDIA-Linux-__REPLACE_ME__.run --uninstall

| improve this answer | |
  • Uhm, isn't it a better idea to use the nvidia-current package and setting up the blacklisting and xorg.conf manually than using the NVIDIA installer? – Nicolay Doytchev May 1 '12 at 14:09
  • It doesn't always work. I spend several days in 10.04 LTS, googling, trying, to no avail. Then I used the installer, problem solved in 15 minutes. Maybe it's different in 12.04. Your millage may vary. – conner_bw May 1 '12 at 14:12

The output of sudo apt-get install mesa-utils && glxinfo | grep direct is direct rendering: Yes

It's working now ; I'm not sure why. I did the suggested 3D check, which was positive, then I checked my desktop session with echo $DESKTOP_SESSION which returned "ubuntu". As far as I know that means it's running unity 3D. Then I did "unity --reset" and suddenly I had wobbly windows. I'm not sure what exactly did make it work.

| improve this answer | |
  • It's working now,I'm not sure why. I had not touched my Ubuntu since you last posted. I did that 3D check which was positive, then I checked my desktop session with "echo $DESKTOP_SESSION" which returned "ubuntu" that as far as I know means it's running unity 3D. Then I did "unity --reset" and suddenly I had wobbly windows. I'm not sure what exactly did make it work but I want to thank you both for your time and effort :). – Tim May 2 '12 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.