2

I recently upgraded to Ubuntu 20.04. Everything worked fine. Two days ago my laptop would boot and get stuck on a black (dark purple) screen. I fixed this by changing the boot parameters, replacing "quiet splash" with "nomodeset" like my google search suggested. This worked. Now for some reason today this fix would lead to a black screen reading

"EFI stub: UEFI Secure Boot is enabled."

and nothing happening.

In BIOS I can't disable Secure Boot. (The option is there but I can't "enter" that field so to speak.)

I now disabled fast boot and which led me to the GRUB command line and I could boot. Then I restarted AGAIN and I got stuck on "EFI stub: UEFI Secure Boot is enabled." again. After enabling fast boot again, I could boot again.

machine ASUS UX303UA.202 What other information could I provide?

Any help is greatly appreciated.

0

2 Answers 2

1

nomodeset

nomodeset only disables the video driver, and should only be used for troubleshooting. Update your video driver. Remember to change "nomodeset" back to "quiet splash".

Secure Boot

See the BIOS update.

fast boot/hibernation

  • boot into Windows
  • open the Power control panel
  • choose change what the power buttons do
  • choose change options that are unavailable
  • uncheck fast startup
  • close the Power control panel
  • open an administrative command prompt window
  • type powercfg /h off
  • type chkdsk /f c:
  • approve to run chkdsk at next reboot
  • type chkdsk /f x: (replacing "x" with drive letters of other visible NTFS partitions)
  • reboot into Windows to let chkdsk run on drive C:

BIOS

ASUS UX303UA

You have BIOS version 202.

There's a newer BIOS that might fix your problem. Version 302, dated 6/5/2019, can be downloaded here.

Note: Confirm that I have the correct web page for your model #.

Note: Have good backups before updating the BIOS.

Note: Disable Secure Boot after updating the BIOS.

1

You can try this:

  1. Log in to recovery mode and then 'resume'
  2. Edit /etc/default/grub, change the line GRUB_CMDLINE_LINUX_DEFAULT so that: "quiet splash" becomes "dis_ucode_ldr quiet splash"
  3. Run: sudo update-grub

Hopefully, this works for you.

3
  • 1
    You should really say what this does as it is rarely a good idea to use this parameter permanently. This parameter disables microcode (firmware) updates which normally happen on every boot. While microcode updates can very occasionally cause boot problems, they are important for security. See wiki.debian.org/Microcode. If someone tries this and finds it does not work, they should revert it. If it does work, they should try to revert it periodically to see if the bug got fixed.
    – Zanna
    May 9, 2021 at 16:52
  • Thank you so much for the information, I even didn't know it.
    – Akkien
    May 10, 2021 at 14:15
  • :) no worries. Welcome to Ask Ubuntu!
    – Zanna
    May 10, 2021 at 17:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .