It is very odd, I added a network drive and can see the files on it. Now I can open some files, but not pdfs. I can open text files and .doc files, but for pdfs I get following error message:

Unable to open document “file:///media/folder/file.pdf”.

Failed to load backend for 'application/pdf': libzstd.so.1: failed to map segment from shared object

I tried copying the file onto my drive and opening it then, same problem. I also tried opening this: http://www.africau.edu/images/default/sample.pdf but it also doesn't work. So I can't open pdfs in general. The strange thing is my collegue also has Ubuntu 20.04 and we both have a fresh default install of Ubuntu and he can open it, but I can't. I didn't change anything regarding the document viewer. How can I open pdfs in Ubuntu 20.04?

  • 1
    Can you try a right click, then "Open With", and then try opening it with Firefox, or whatever web browser you have. Alternatively, you can copy this address of the file (file:///media/folder/file.pdf) that you have given, and paste it directly in the search bar of the browser. – Crazy Goblin Nov 17 '20 at 9:18

Ok, after shortly switching to Windows and then back again, so restarting the computer this works again. I'm still curious how it could happen that such a basic thing as opening pdfs got broken.


I think your default PDF viewer is broken. Please try reinstall evince,qpdfview or somethink like app. On 18.04, they can be installed like: sudo apt install evince qpdfview (no sure if 20.04 is same or not)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.