I have a 2TB USB Windows hard drive which suddenly became RAW.
The hard drive contains only HD movies, mkv files. There's no OS there.

From this link and this link, it seems I may get the chance to recover the data using Ubuntu Live CD.
So I download the Ubuntu iso file and burn it to a blank DVD.

After I boot from the Live CD, I use the "Try Ubuntu" option, but the raw drive is not listed in "Files" directory as seen below :
enter image description here

After playing around what is inside the Ubuntu desktop, I found a "Disks" icon, so I double click it and it show the raw drive (orange highlighted) :
enter image description here.

Based from reading in the internet, I open the terminal window and type sudo fdisk -l, and the result is below :
enter image description here
with red text "partition 1 does not start on physical sector boundary" at the bottom.

The CrystalDisk information result show like below:
enter image description here

I need help from the experts if there is a way to have Ubuntu read the raw hard drive and explore it so I can copy it to another hard drive.

Any kind of respond would be greatly appreciated.
Thank you in advanced.

PS : Sorry I forgot to mention that I've tried TestDisk from Windows 10. But it seems there is something wrong with the drive which cause it became so hot after about 3 hours of Deeper Search. So I stop it. I post this "hot" problem in the Super User SE.

  • What file system does the volume use?
    – Nmath
    Nov 17, 2020 at 2:09
  • RAW means it lost its format. And it is both in partition table which shows NTFS, but also in the partition boot sector (BS or PBR). NTFS has a backup BS that you may recover. But that it now shows it starts at sector 2 may be a separate issue. A 4K drive should start at sector 2048, normally, but at least some sector divisible by 8. Did start sector also get changed.
    – oldfred
    Nov 17, 2020 at 2:43
  • @Nmath, too bad - I don't know what file system the hard drive use. Thanks for the comment.
    – karma
    Nov 17, 2020 at 6:45
  • @oldfred, oh I see. So actually the BootStart should start at 2048 normally. But mine show is start at 2. Thanks for the comment.
    – karma
    Nov 17, 2020 at 6:48
  • Do you have packages exfat-fuse and exfat-utils installed? I ask for the file system type because you might need additional packages. exFAT file systems should still show up as such, but its worth a shot to verify that your system has exFAT capabilities.
    – Nmath
    Nov 17, 2020 at 8:17

1 Answer 1


Your disk has been marked as "raw" because the filesystem was corrupted for some reason (not ejecting, not shutting down, bad luck, whatever). You can likely repair the disk with a command line tool known as fsck. You may want to look at this U&L post, as well as here. You're going to want to boot into the live CD / USB drive and run fsck from a terminal. From man fsck:

fsck [-sAVRTMNP] [-C [fd]] [-t fstype] [filesys...] [--] [fs-specific-options]

What this means is you need to find the identifier of your disk (in your screenshot /dev/sda1, though you should check again with sudo fdisk -l to be sure, especially after reboots), and run the command:

sudo fsck -t NTFS /dev/sda1

(replace NTFS with FAT32 if that was the format of the drive). If all goes well (which it may not), you should be able to mount the disk manually or reboot your computer and access the drive. If fsck has errors, edit your answer to include them as well.

  • Hi Pixelated Fish, thank you for your answer. The problem is I don't know the format of the drive. I bought the drive which already contains the mkv files. My bad, I never check what is the format of the drive. From the photo I post, it say "Partition Type : HPFS/NTFS/exFAT", so I don't know which one should I write in sudo fsck -t ??? /dev/whatever-theRawdisk-id-show-in-ubuntu. Will it be a disaster if I try it each of them ?(HPFS, NTFS, exFAT). Thank you once again
    – karma
    Nov 17, 2020 at 6:50
  • BTW, running the "Try Ubuntu" from the Live CD it seems I won't be able to restart ? Because yesterday I've tried to restart but then it boot again from the Live CD.
    – karma
    Nov 17, 2020 at 6:50
  • @karma I’m not to sure what happens if you pass fsck the wrong file system, but you might want to try it without one; I believe it will auto detect if it can. And when you reboot your computer, depending on how you got to the live CD, you may need to either change your boot order back or press like “F12” or something (depending on your computer) to choose your boot volume. Nov 17, 2020 at 14:28
  • 1
    If format is NTFS as it seems, better to run Windows repair like chkdsk The Linux dosfsck (fsck.fat) or the ntfsFix only does minor repairs and sets the chkdsk flag so Windows will run that anyway.
    – oldfred
    Nov 17, 2020 at 14:35
  • @oldfred Yeah probably so if OP has access to a Windows machine. Nov 17, 2020 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.