I have just upgraded my work pc to 12.04 (not upgrade, fresh install), installing updates during the install, and after everything has loaded (with no errors) and I restart I get brought to console 1 tty login.

Console 7 looks like this: enter image description here

IIRC I did not have to finagle with my drivers on 11.10 to get this card working. If this is in fact a driver bug I will remove this post and submit the bug but i'm not 100% confident that it is.

I attempted to run unity --reset and got this: enter image description here

Lastly I tried $ sudo apt-get install nvidia-current which tells me nvidia-current is already the newest version. so I ran $ sudo dpkg-reconfigure nvidia-current which says /usr/sbin/dpkg-reconfigure: nvidia-current is broken or not fully installed. Anything I can try from here would be awesome.
Currently the only way to get the system up and running was to shut down, plug one of my monitors into the onboard video, enable the onboard video card from the BIOS, then boot back up (and on my single monitor everything is fine).


So I have been able to boot fresh with the ext card plugged in as long as I don't take the updates with the install.
past this if I only install the nvidia drivers (nvidia-current or nvidia-current-updates) from the main server (or canadian) I then get the problems..

My proposal; which I don't know where to look for:
Can I try installing the previous version of this driver? In the past, on another machine I had issues with my NIC driver being funky... downgraded to the previous driver and bam everything was merry and well.

  • Tried that and no better.. fresh installing then i will try again. I dont trust my meddling didnt make it worse – rlemon May 1 '12 at 14:26

Disable the onboard video and go back to using the Nvidia card and boot to a command line.


Move your nvidia settings:

mv ~/.nvidia-settings-rc ~/.nvidia-settings-rc.bak

Move your xorg.conf:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

Remove the driver completely:

sudo apt-get remove --purge nvidia-current

Reboot, then reinstall the driver:

sudo apt-get install nvidia-current

Reboot again and have the driver generate a default config:

sudo nvidia-xconfig

Reboot a final time and you should have a working X session. You can now log in and reconfigure your setup (set resolution, setup dual monitors or whatever else you need to do).

| improve this answer | |
  • Didnt work.. and now my onboard gd resolution is stuck at 720*400 ... i have a 24" display – rlemon May 1 '12 at 13:37
  • Were you using the nvidia card when doing all of the above? – Toby May 1 '12 at 13:40
  • yes...i followed your steps to the letter. now i'm stuck looking at i.stack.imgur.com/nolEv.png :P this is horrific. – rlemon May 1 '12 at 13:42
  • OK, let's restore the previous settings... but only restoring xorg.conf at first - may have been an issue in your .nvidia-settings-rc. Run sudo mv /etc/X11/xorg.conf.bak /etc/X11/xorg.conf – Toby May 1 '12 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.