I use (k)ubuntu to work, and now that I have to use video call applications daily, I've noticed the subpar quality of my integrated mic. I know my bluetooth headset works as a headset because I've used it on my phone as a bluetooth headset, and it even shows up in the volume mixer as a headset. When I connect the headset to my pc, I can use a2dp(stereo playback), but cannot use my microphone. When I try to switch to hsp/hfp in pulseaudiovolumecontrol, I can hear my own voice echoing in my headset, but can no longer hear anything from my pc. However, I can see in my volume manager that the microphone is now available(although it doesn't work). here are some details on my hardware:

my wifi/bt card according to lspci:

3b:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)

PACMD output:

    index: 2
        name: <bluez_card.FC_58_FA_C4_9D_17>
        driver: <module-bluez5-device.c>
        owner module: 28
                device.description = "JLab BT"
                device.string = "FC:58:FA:C4:9D:17"
                device.api = "bluez"
                device.class = "sound"
                device.bus = "bluetooth"
                device.form_factor = "headset"
                bluez.path = "/org/bluez/hci0/dev_FC_58_FA_C4_9D_17"
                bluez.class = "0x260404"
                bluez.alias = "JLab BT"
                device.icon_name = "audio-headset-bluetooth"
                device.intended_roles = "phone"
                headset_head_unit: Headset Head Unit (HSP/HFP) (priority 30, available: unknown)
                a2dp_sink: High Fidelity Playback (A2DP Sink) (priority 40, available: yes)
                off: Off (priority 0, available: yes)
        active profile: <a2dp_sink>
                bluez_sink.FC_58_FA_C4_9D_17.a2dp_sink/#8: JLab BT
                bluez_sink.FC_58_FA_C4_9D_17.a2dp_sink.monitor/#12: Monitor of JLab BT
                headset-output: Headset (priority 0, latency offset 0 usec, available: yes)

                headset-input: Headset (priority 0, latency offset 0 usec, available: unknown)

Also now looking at my journal for bluetooth-related errors I see some lines that raise questions:

Unable to get io data for Headset Voice gateway: getpeername: Transport endpoint is not connected (107)
Failed to release transport 

/org/bluez/hci0/dev_FC_58_FA_C4_9D_17/sep1/fd7: Method "Release" with signature "" on interface "org.bluez.MediaTransport1" doesn't exist

Bluetooth: hci0: Failed to send Intel_Write_DDC (-22)

Update: I tried to update to groovy gorilla, as I thought that it may remedy my issue as stated in https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1871794 but it didn't work out, so I've updated the title to 20.10

  • I would suggest you try this and see if it helps. – Raffa Nov 18 '20 at 20:19
  • Iti didn't work sorry, same result as before, I did get this new line in my system log from bluetoothd though: Control: Refusing unexpected connect – Jake t Nov 19 '20 at 2:26

Alright, so an update to bluez and the audio stack that fixes this just came out today(23 november 2020). All one needs to do to apply the fix is: sudo apt update && sudo apt upgrade -y and your wireless ax200 card should accept hsf/hfp. Note that I'm doing this on groovy gorilla, I am unsure of any support for this in lts versions(but if you do the above step and this dosen't work, you should try using do-release-upgrade). NOTE: the audio is very low quality for the hfp profile, I've made a switcher based on another script, and my switcher is available here for all interested parties who want to be able to use push-to talk. Just put your headphone's mac address in the textbox and toggle with the button

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.