1

Realtek Semiconductor Corp. RTL8811AU 802.11a/b/g/n/ac WLAN Adapter

Installed 20.04 a few weeks ago and used a RALink USB device to access the internet because 20.04 doesn't support the Realtek devices out of the box. Installed RTL8811au drivers at that time and have used that high gain USB dongle up until Nov. 12, 2020 when I auto-upgraded 20.04 and rebooted. As soon as I rebooted, there was no connection any Wifi sources. The Realtek USB drivers were knocked out and the USB dongle no longer worked...but it IS shown:

lsusb \snip

Bus 001 Device 007: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 009: ID 0bda:a811 Realtek Semiconductor Corp. RTL8811AU 802.11a/b/g/n/ac WLAN Adapter

I've checked and all the threads I've found to fix this are old, mostly apply to the RTL8812au drivers. My device is an 8811au. I have tried those suggestions of course and so far none of them work and I'm afraid I'm clogging up my system with all the installs that lead no where.

Anyone have a suggestion for where to get working drivers and to installing them? Step by step? Some method that is recent and applies to 20.04.1?

I found a previous question and a "I found it!" comment showing this link to a newer driver: https://github.com/aircrack-ng/rtl8812au

But what am I suppose to do there? There's far too much info there, how do I install what I need???

Thanks.


@heynnema Thanks for helping...I'm right at the end of an electronics project so I got distracted. Sorry I'm so late getting back here to this. Here are your answers:

dkms status - returns null. Nothing listed.

sudo lshw -C network

  *-network                 
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: enp4s0
       version: 09
       serial: 08:60:6e:74:7a:96
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 firmware=rtl8168f-1_0.0.5 06/18/12 latency=0 link=no multicast=yes port=MII
       resources: irq:18 ioport:e000(size=256) memory:d0004000-d0004fff memory:d0000000-d0003fff
  *-network
       description: Wireless interface
       physical id: 1
       bus info: usb@1:4
       logical name: wlx1cbfce112175
       serial: 1c:bf:ce:11:21:75
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rt2800usb driverversion=5.4.0-53-generic firmware=0.36 ip=192.168.43.109 link=yes multicast=yes wireless=IEEE 802.11

uname -r

5.4.0-53-generic

@heynnema Then I followed your instructions as shown below in your post but receive this error mess:

sudo dkms remove rtl8812au/5.6.4.2 --all
Error! There are no instances of module: rtl8812au
5.4.0-53 located in the DKMS tree.

@heynnema I went ahead and downloaded the zip and tried to install. Got messages,

'Kernel preparation unnecessary for this kernel.  
Skipping...' &  'No original module exists within this kernal' and finally,

dkms status

Error! Could not locate dkms.conf file.
File: /var/lib/dkms/rtl8812au/5.6.4.2/source/dkms.conf does not exist.

So now what?

@heynnema Does it matter that we keep getting driver headers that say 8812 but mine is an 8811? Also, just to point out, this device worked fine up until the last Ubuntu software autoupgrade. I seldom pay attention to what is being downloaded and installed though so didn't notice anything having to do with Realtek.

@heynnema Did this as you asked...would like above ? answered before doing all the other stuff you asked for below. Thanks for the help.

ls -al /usr/src/rtl8812au-5.6.4.2/ ls: cannot open directory '/usr/src/rtl8812au-5.6.4.2/': Permission denied

3
  • Let us continue this discussion in chat. – heynnema Nov 18 '20 at 15:05
  • ls -al /usr/src total 28 drwxr-xr-x 7 root root 4096 Nov 18 07:01 . drwxr-xr-x 14 root root 4096 Oct 30 07:29 .. drwxr-xr-x 3 root root 4096 Nov 6 12:51 libdvd-pkg drwxr-xr-x 24 root root 4096 Oct 30 08:26 linux-headers-5.4.0-52 drwxr-xr-x 7 root root 4096 Oct 30 08:26 linux-headers-5.4.0-52-generic drwxr-xr-x 24 root root 4096 Nov 13 16:20 linux-headers-5.4.0-53 drwxr-xr-x 7 root root 4096 Nov 13 16:20 linux-headers-5.4.0-53-generic – Jim_HiTek Nov 18 '20 at 15:06
  • @Jim_HiTek Please don't put RESOLVED, SOLVED, FIXED etc. in the question title. This is a question answer site. The green check mark ✅ next to the correct answer is sufficient. Please see the site help for more how to use this site. – user68186 May 12 at 21:00
3

In the past, you might have installed (sudo apt-get install or sudo make install) static drivers for this device. The problem is that with every kernel update, like with Software Updater, the driver breaks.

Here, we'll change to a dkms driver, and this will rebuild itself during kernel updates, so you won't have to worry about this again. See man dkms for more info.

enter image description here

  • Locate this file in your downloads area

enter image description here

  • Right-click on this icon and select "Extract Here"

  • Confirm this folder in your downloads area

enter image description here

  • Right-click on any white space in your downloads area

  • Choose "Open in Terminal"

  • In the terminal type:

sudo cp -r rtl8812au-5.6.4.2 /usr/src # copy the folder to /usr/src

sudo dkms add rtl8812au/5.6.4.2 # dkms add the folder

sudo dkms build rtl8812au/5.6.4.2 # dkms build the software

sudo dkms install rtl8812au/5.6.4.2 # dkms install the software

dkms status # confirm its status

16
  • "The problem is that with every kernel update, like with Software Updater, the driver breaks. Here, we'll change to a dkms driver, and this will rebuild itself during kernel updates, so you won't have to worry about this again. See man dkms for more info." Another upgrade and Ubuntu wiped out the Realtek. So the long term fix didn't work. I'm gunna try it again. Boy this is really annoying. – Jim_HiTek Dec 20 '20 at 3:17
  • @Jim_HiTek This answer is a permanent fix. Show me dkms status when you're done. – heynnema Dec 20 '20 at 15:36
  • Not sure what you mean by 'this answer is a permanent fix'? Remember we went to 'Chat' because the above changes didn't work? I don't know how to get back to that Chat area but what I followed there did restore the Realtek operation. And also, it didn't really work long term because my Realtek works fine on Win10, but not Ubuntu now. Just a month later. Oh, wait, did you move that answer that worked here from Chat? Ok, I'll check that. – Jim_HiTek Dec 21 '20 at 16:20
  • @Jim_HiTek I reviewed the chat. After a few struggles, we did have it working. Has something changed? Show me dkms status. – heynnema Dec 21 '20 at 16:33
  • dkms status rtl8812au, 5.6.4.2, 5.4.0-58-generic, x86_64: installed..............Okay, it's back and works. Did you change something so it's permanent now? Oh, and THANKS!!! – Jim_HiTek Dec 21 '20 at 16:34
0

This just short Tutorial for NEWBIE (like me!) for installing driver USB Wifi driver for Linux Debian and it’s derivatives (Debian, Ubuntu, Linux Mint, Pop! OS, Elementary OS, etc.)

When you're switch to new OS distro or updating OS or accidently delete some part of software sometimes your Wifi driver are no support / no working and got blank your mind ... Yup thats right !

First STEP to do :

  1. You only need YOUR SMARTPHONES and make sure also they have “Internet Mobile Data”.
  2. Then you need to opened “Developer Options” on your smartphone to do that first before.
  3. Open your phone “Settings” and find it “About Phone” and selected “Version Number” and then now repeated click up to (7x) seven times.
  4. Inside “Developer Options” find it or scrolling to the “Network” and selected “Select USB Configuration” and then select again to the “USB Ethernet (RNDIS)”.
  5. After this all you need is USB cable connected to your PC or Laptop and it’s done, now you ready online!

Second STEP to do :

  1. Installing GDebi (I’m using Geary on Pop! OS that are the same software). You can find GDebi in Ubuntu Software Center, just search for it and install it from there.
  2. Then installing the latest “realtek-rtl88xxau-dkms” deb package from Kali’s repository (Link below!).
  3. After this just type in your linux terminal “sudo reboot” to rebooting your PC or Laptop.
  4. It’s done , just try to check it out !

I’m trying many times using this method when i switching to new OS distros or update Linux Kernel. This really saving my times and work to do! Thanks for your time to read this !

Source :

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.