I upgraded from 10.10 to 12.04, and now can't log in any more. The password is correct- when I type in a wrong one, I am told it's incorrect, while the correct one is seemingly accepted, but then just takes me back to the login page. I can login as guest, but I can't do anything with the shell as it, too, doesn't accept my password.

  • 1
    This was happening to me when I'd unistalled nautilus. If this the reason (because of broken upgrade or something like this) then, while you are on the login screen, you can press Ctrl+Alt+F1 and you will have a terminal, type in your login name and password (which will not be shown, not even asterisks (*) will be shown) and then you can try sudo apt-get --reinstall nautilus, then press Ctrl+Alt+F7 to go back to the login screen and reboot! – hytromo May 1 '12 at 11:21
  • Thanks- while the terminal accepts my password, it says nautilus is an invalid operation. It says the same about grub, which I've also tried to reinstall – Scout Fox May 1 '12 at 11:28
  • my bad, try sudo apt-get install --reinstall nautilus – hytromo May 1 '12 at 12:16
  • tried that, and it worked fine- didn't solve the problem, though. Anyway, thanks for your help! – Scout Fox May 1 '12 at 14:07
  • possible duplicate of Ubuntu gets stuck in a login loop – Eliah Kagan May 13 '15 at 0:02

try removing the Xauhority file and reboot.

for me that was

rm ~/.Xauthority


|improve this answer|||||
  • 1
    using the livecd – nastys May 1 '12 at 20:44
  • 1
    I just had the same problem and that solved it from the Ctrl+Alt+F1 prompt. Any idea why this happens? – jadkik94 Sep 11 '12 at 14:02

Answer from anonymous user:

I have exactly the same problem and I fixed it by the following solution (found here):

  • Press CTRL+ALT+F1
  • Log in with you user name and password

  • Run the following command: sudo chown -R $USER:$USER $HOME

  • Press CTRL+ALT+F7

  • Try to log in
|improve this answer|||||
  • 1
    it worked thank you. Might I ask what had happened to warrant the said error? – mojo706 Feb 17 '14 at 8:52

Check if the user has the same userid (and groupid) as the files in the user's home directory. If the user has id 1000 and the files in the user's home directory have 1001, correct the user in the /etc/passwd file to userid 1001.

|improve this answer|||||

Well, follow the instructions indicated here startx doesn't work

I can't gurantee though that it will work for you as well.

That means:

  1. try to get a recovery console by using the shortcut Ctrl-Alt-F1. Check first, whether you got write-rights. If not use the option clear to get them.

  2. Now remove the xAuthority files sudo rm /home/username/.Xauthority*

  3. try to reinstall xorg by using sudo apt-get install --reinstall xorg

  4. now reboot with the command sudo reboot. Everything should work fine.

I had the same problem after an analysis of the error i get when i tried startx I figured that Xserver is the origin of the problem.

|improve this answer|||||

I just had this problem after I updated. I figured out that it had to do with my gnome-shell I was using. So I did the following:

$ cd etc/apt/sources.list.d/
$ sudo rm gnome3-team-gnome3-precise.list gnome3-team-gnome3-precise.list.save
$ reboot

And now I'm able to login!

|improve this answer|||||

I had the same problem. My understanding of the problem is as follows. It occurs if you encrypt you file system during the upgrade and you change the password.

Solution. login as guest. go to user account control. change the password of your normal user to the original password. log-off and log on with you normal user. you should be able to log n now as the file are now decrypted.

At least i worked form me.

|improve this answer|||||
  • But you don't want to decrypt your file system! That's a working non-solution... – Patrick Da Silva Jun 26 '16 at 0:40

What worked for me was to install byobu, that was enabled in 10.04 and unnistalled during upgrade, so that broke the graphical login (only errored in console).

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.