This question already has an answer here:

Upon upgrading to 12.04 I installed Minecraft, Openjdk 6 and 7. When I login everything is fine, but after that I get the "Updating Minecraft" screen for about 0-5 seconds, then the screen goes black. I waited for about 5 minutes and eventually MC crashed and an error report came up.

Minecraft: Minecraft 1.2.5 OS: Linux (i386) version 3.2.1-24-generic-pae Java:1.6.0_24, Sun Microsystems Inc. VM: OpenJDK Server VM (mixed Mode), Sun Microsystems Inc. LWJGJ: 2.4.2 [failed to get system properties (java.lang.NullPointerException)]

org.lwjgl.LWJGLEXCEPTION: coulod not init GLX at org.lwjgl.opengl.LinuxDisplayPeerInfo.initDefaultPeerInfo (Native Method) at org.lwjgl.opengl.LinuxDisplayPeerInfo.(linuxDisplayPeerInfo.java:52)

There's some more to the report, tell me if you want me to continue, I have to type all this by hand because I can't copy paste the error report. The rest of the lines are a bunch of at blah.blahblah.blah.

marked as duplicate by Luis Alvarado Mar 13 '13 at 23:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • That script worked. Being new to Ubuntu and Linux I had to figure out how to make it work but alas. It worked. Thank you Eric and Darkboy – user140098 Mar 13 '13 at 23:37

In Minecraft 1.2.5,the LWJGL files were updated. Mojang forgot to update their database with the new LWJGL linux files. You need to update them yourself(this will be fixed in MInecraft 1.3). Here is the wiki link with instructions: http://www.minecraftwiki.net/wiki/Tutorials/Update_LWJGL


On the older versions of Ubuntu, you could fix that with

sudo apt-get install sun-java6-jre sun-java6-plugin

But those packages don't seem to be in the repositories for Precise.

  • See questions here related to java for a possible workaround to that. – belacqua May 29 '12 at 18:39

When updating ubuntu my video-card driver always need to be updated or i will encounter a blackscreen folowed by an errormessage when starting minecraft.

my advice would be to search for a new driver to you card from your cards manufacturer as they probably make a supported linux version, (Ati for example)

This might solve your problem. If not you can always try updating your lwjgl package manualy with this guide: http://www.minecraftwiki.net/wiki/Tutorials/Update_LWJGL

Good luck!


Save this in a file and run it on terminal to fix the Minecraft black screen on Linux/Ubuntu

#!/usr/bin/env bash

echo "Determining OS..."

if [[ "$(uname -s)" == "Linux" ]]; then
elif [[ "$(uname -s)" == "Darwine" ]]; then
    mcdir="$HOME/Library/Application\ Support/Minecraft/"
    echo "OS not supported.  Exploding..."
    exit 1

echo "Detirmining LWJGL latest version..."

latest=$(wget -q -O - http://lwjgl.org/download.php |\
        grep -o  "https:\/\/sourceforge.net\/projects\/java-game-lib\/files\/Official%20Releases\/LWJGL%20[0-9|\.]*")

echo "Detirmining download URL..."

dlurl=$(wget -q -O - "$latest" |\
        grep -o -m1 "http://sourceforge.net/projects/java-game-lib/files/Official%20Releases/LWJGL%20[0-9|\.]*/lwjgl-[0-9|\.]*.zip")

echo "Checking if ~./cache/ exists..."

if [[ ! -d "$HOME/.cache/" ]]; then
    echo "~./cache/ did not exist.  Creating..."
    mkdir "$HOME/.cache/"

echo "Downloading latest LWJGL..."

wget -q -O "$HOME/.cache/lwjgl.zip" "$dlurl"

echo "Extracting zip file..."

unzip -qqo "$HOME/.cache/lwjgl.zip" -d "$HOME/.cache/"

lwjgldir=$(find "$HOME/.cache" -maxdepth 1 -type d -name "*lwjgl*" -print)

echo "Copying files..."

for i in "jinput" "lwjgl" "lwjgl_util"; do
    echo "Copying $i..."
    cp "$lwjgldir/jar/$i.jar" "$mcdir/bin/"
for i in "libjinput-linux" "libjinput-linux64" "liblwjgl" "liblwjgl64" "libopenal" "libopenal64"; do
    echo "Copying $i..."
    cp "$lwjgldir/native/linux/$i.so" "$mcdir/bin/natives/"

Not the answer you're looking for? Browse other questions tagged or ask your own question.