6

This happend when I did something:

hck

I could then only write commands, make shortcuts and move the cursor(cannot click on anything).

I rebooted then and the problem was solved.

Why did it happend and are it better ways to solve it?

UPDATE:

input:

xkill

output:

Select the window whose client you wish to kill with button 1....
xkill: unable to grab cursor
5
  • Can be a bug or something. Did this happened many times or just once. If it is more than one, can you try clear command when this happens in terminal once. Commented Nov 14, 2020 at 13:56
  • It happend only one time. Commented Nov 14, 2020 at 14:04
  • 1
    Just submit a bug report. If they found it true then the bug will be removed in ther next version and have a good time:)) Commented Nov 14, 2020 at 14:06
  • Now it happends twice. Commented Nov 18, 2020 at 14:44
  • And it is not because screensot. Commented Nov 18, 2020 at 17:37

2 Answers 2

5

From a question that I asked there was an answer that said:

I faced the same problem on Pop_!OS, no need to reboot actually;
The easier way is to just restart GNOME by one of two ways:

  • pressing Alt + F2, type r then Enter, or
  • in terminal, killall -3 gnome-shell

This should just restart Gnome Shell. You will not lose your open windows, but you should be reminded to save all your work >regularly!

Related bug: https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1824874

Solution

The answer works in this question too. Open terminal by pressing Ctrl + Alt + T.

2
  • 1
    The answer worked, but I have a second question: Why did it happened? Commented Mar 21, 2021 at 14:18
  • @mansojang1024, I don't know why, sometimes it just happends for me.
    – MandiYang
    Commented Mar 21, 2021 at 14:21
0

I the solved same problem this way:

  1. I opened the terminal by pressing Ctrl+Alt+T.

  2. I found Nautilus's PID:

    ps ax | grep /usr/bin/nautilus
    
  3. I killed the process using the kill command:

    kill 1234
    

    where 1234 is the PID I found with the previous command.

As a one-line command:

kill $( ps ax | grep /usr/bin/nautilus )

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .