0

Say you have two language layouts: French and German. You set a shortcut to switch layouts, and the shortcut is Alt+Space. If the current language is French and you press Alt+Space, it switches properly to the next language, German. However, pressing the combination again does not switch back to French. Simply, it stops working. It works again when you manually go back to French.

This occurs in several flavors I've interacted with: I tried this on Kubuntu 20.10, Xubuntu XFCE 20.04, and Lubuntu 20.04 LXQT. For these three I used the latest most popular releases.

How do I repair this problem so I can continuously switch languages whenever I press Alt+Space?

4
  • Sorry, this is my first post here. I tried this on Kubuntu 20.10, Xubuntu XFCE 20.04, and Lubuntu 20.04 LXQT. For these three I used the latest most popular releases. I also got to try it on Kubuntu 14.04 Trusty Tahr but didn't try it on EOL/ESM releases of other flavors. I checked to see if the problem existed back then or if it's new.
    – user1147965
    Nov 14, 2020 at 7:11
  • Please edit your question and add those details there (also remove the off-topic detail) Kubuntu 14.04 LTS (the 2014-April release, thus 14.04) had 3 years of supported life (5 years is main Ubuntu 14.04 only), ending in 2017-April thus is off-topic now due to EOL (end-of-life) status, with no ESM is offered for flavors like Kubuntu (but ESM is off-topic here too, supported only by Ubuntu Advantage). Also narrow done to a single desktop, the solution can vary on desktop (even release).
    – guiverc
    Nov 14, 2020 at 7:23
  • Lubuntu uses fcitx (manual.lubuntu.me/stable/3/3.1/3.1.1/fcitx.html), but not all desktops use that tool. Alt+Space already has a function for the desktop though.
    – guiverc
    Nov 14, 2020 at 12:04
  • I will try a different shortcut and see if anything changes, though I highly doubt it, since I reproduced the same effect on another computer. Do you know what tool Xubuntu and Kubuntu use instead of fcitx? I'll also install Ubuntu on both computer and see if the problem is elucidated.
    – user1147965
    Nov 14, 2020 at 17:31

1 Answer 1

0

I tested this on Kubuntu 20.10. Even if I couldn't reproduce the exact behavior you describe, I noticed that the shortcut Alt+Space conflicts with other shortcuts specific to the KDE desktop.

The shortcuts you are offered to choose between (at least on the KDE desktop) are XKB shortcuts. When picking such a shortcut, you need to make sure that it works well together with the desktop environment you are on.

Alt+Space seems not to be optimal on Kubuntu. I changed it to Win+Space, and then it worked smoothly.

3
  • Do you have an idea what's causing this? I reproduced the same effect on an old iMac I have as well as on a 2018 HP laptop. I'm comfortable with assigning another shortcut combination, it's just that having this dead end makes typing clumsy.
    – user1147965
    Nov 14, 2020 at 17:27
  • @BlandBoomer: Not sure what you mean with "causing". Alt+Space is already taken by the desktop, that's it. Possibly it can be disabled in the desktop settings, but in that case the exact method varies between different desktops. (Many users find that using CapsLock for switching input sources is convenient.) Nov 14, 2020 at 19:02
  • Indeed Alt+Space as well as Alt+Shift are problematic. I tried Win+Space and Ctrl+Shift; there, continuous switching is working just fine.
    – user1147965
    Nov 14, 2020 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy