My PC has separate SSD drives for windows and linux. My Fenvi AX200 WiFi/BT card worked fine in windows after I manually installed drivers for it. In Linux ubuntu budgie 20.04 the Bluetooth works but not the WiFi. It says "No Wi-Fi adapter found" and I have no internet unless I plug in a cable which is awkward. I am inexperienced with linux, have just done my first install. Any help would be appreciated. A link to the card is on https://www.aliexpress.com/item/33039932105.html?spm=a2g0o.productlist.0.0.7ce4261dUVhlVF&algo_pvid=2f28a6e3-9eb5-442a-8703-6924f355137c&algo_expid=2f28a6e3-9eb5-442a-8703-6924f355137c-0&btsid=0bb0623216051844639588700e5e74&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_ It says there that the card only works in windows and yet the bluetooth part of the card is working fine in linux, though volume is low.

In the terminal I got

john@john-desktop:~$ lspci -nnk |  grep 0280 -A3
08:00.0 Network controller [0280]: Intel Corporation Wi-Fi 6 AX200 [8086:2723] (rev 1a)
    Subsystem: Intel Corporation Wi-Fi 6 AX200 [8086:0084]
    Kernel modules: iwlwifi
09:00.0 Non-Essential Instrumentation [1300]: Advanced Micro Devices, Inc. [AMD] Starship/Matisse PCIe Dummy Function [1022:148a]


john@john-desktop:~$ dmesg | grep iwl
[    5.125006] iwlwifi 0000:08:00.0: enabling device (0000 -> 0002)
[    5.223816] iwlwifi: probe of 0000:08:00.0 failed with error -110
  • The fenvi website only offers drivers for windows not for linux Nov 12, 2020 at 15:16
  • Please edit your question to show the result of these terminal commands: lspci -nnk | grep 0280 -A3 and also: dmesg | grep iwl Possibly helpful: askubuntu.com/questions/1269313/ax200-wifi-and-20-04 Welcome to Ask Ubuntu.
    – chili555
    Nov 12, 2020 at 15:35
  • Is it a dual boot with Windows?
    – Pilot6
    Nov 12, 2020 at 16:12
  • Thanks chili, I edited my post as requested. The first lspci grep tells me the system can see the card ok and the dmesg tells me that enabling it failed, but as a newbie that's all I can tell from those. I had seen the post you reference but never had ubuntu 18 so it does not solve my issue yet. Nov 12, 2020 at 16:17
  • Hi Pilot, no I have 3 ssds one with linux installed, one with win 10, and one for data which they will both use I hope. Nov 12, 2020 at 16:18

1 Answer 1


Boot into Windows, disable Fast Startup feature there, then reboot to Ubuntu.

Windows doesn't shutdown by default and that is the problem.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.