I am using Ubuntu 20.04(Gnome3.36) and need help with this:


The Authentication Required window is stuck right after logging in and I can't close it. I tried using xkill to close the window but it didn't close, I think xkill doesn't recognize the Authentication required window as a window.

I searched for answers but only found a reddit post which the author has the same problem, which is https://www.reddit.com/r/gnome/comments/fscvql/authentication_required_window/

Is there any easier ways to remove it than rebooting?

UPDATE 2022-12-27:

On Ubuntu 22.04 I don't encounter this problem anymore, the issue seems to be fixed. But I also can't restart the gnome shell as I am now using Wayland.

  • but on ubuntu 20.04.6 it still exists. I think I should not need to update major version to get this out
    – Darius.V
    Commented Aug 11, 2023 at 8:49

4 Answers 4


I faced the same problem on Pop_!OS, no need to reboot actually;
The easier way is to just restart GNOME by one of two ways:

  • press Alt + F2, type r then Enter


  • in terminal, type killall -3 gnome-shell

This should just restart Gnome Shell. You will not lose your open windows, but you should be reminded to save all your work regularly!

Related bug: https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1824874

  • I used the killall command and that worked.
    – tnk479
    Commented Jan 2, 2021 at 22:34
  • 8
    Note that this will not kill your session nor any open programs. It is non-destructive. Commented Jan 29, 2021 at 14:53
  • 1
    I was about to restart the whole computer and then I see this solution. Thank you so much. Commented Feb 4, 2021 at 11:45
  • @AnanRaddad Hi, I used your method several times, but I changed gnome keyboard shortcut, and assigned Alt+F2 to something else. So I can't use Alt+F2. (a search tells me the default Alt+F2 was 'Run Console' but I can't find the menu in the keyboard shortcut edit window) Please help me.. what can I do in this case?
    – Chan Kim
    Commented May 25, 2021 at 5:40
  • 1
    For me, this kills emacs windows on ubuntu 20.04.
    – Ryogi
    Commented Oct 18, 2021 at 17:49

I don't recommend the killall -3 gnome-shell approach because:

  • It causes Steam and any running games within to exit.
  • It has a weird side effect of bringing up new instances of GUI apps like 1Password rather than bringing up the existing minimized process.

I use the following alias 'gf' for "gnome fix":

For zsh and bash:

alias gf='dbus-send --type=method_call --dest=org.gnome.Shell /org/gnome/Shell org.gnome.Shell.Eval string:"global.reexec_self()"'

For fish:

alias gf 'dbus-send --type=method_call --dest=org.gnome.Shell /org/gnome/Shell org.gnome.Shell.Eval string:"global.reexec_self()"'
  • Now when I see that your solution also works, I am not gonna change the accept mark since I already placed it for a year ago but you got my upvote :)
    – MandiYang
    Commented Feb 27, 2022 at 16:26
  • Both solutions work! I'm just noticing weird artifacts with one versus the other. Thank you. :)
    – Michael
    Commented Feb 28, 2022 at 17:09

Thank you for the nice tip!

For me it started happening seemingly all of a sudden. I am on a fresh Linux installation. Other than playing around with power management (suspend and hibernate) to make them work better, I did not fiddle around with anything else. It is happening after I login from suspension/reboot.

After a couple of days of trying to understand what might be wrong, I noticed a couple of things:

  • When trying to restart the window did not only display the 3 buttons Cancel, Restart, Power off BUT it stated that there is another user logged in (with the same name as me). I checked how many users were logged in but there was only one (me)
  • The authenticate window popup was popping up when I was trying to reboot (with the message ~= "authentication is needed for reboot")
  • All of a sudden the brightness control stopped working and my screen brightness was not changing when I was updating the slider (I know weird...but again I had done nothing to fiddle around with it)

Those clues led me to think that the latest package I had installed might be the culprit. It was the "chrome remote desktop" package which is related to logging the user to the current active window session and touching on display properties..

And after uninstalling the package everything worked as before! No stuck authentication popups, no duplicate ghost users and I can control my display's brightness.

I hope those observations and my experience is useful to someone out there.

  • Very interesting. However, I'm using RDP to connect into multipass! hahaha. Still upvoting.
    – jhchnc
    Commented Jul 1, 2022 at 23:25

I solved same problem this way:

  1. I opened terminal: Ctrl + Alt + T,
  2. I found nautilus PID: ps ax | grep /usr/bin/nautilus
  3. I killed process by kill command: kill 1234

One-line command is: echo $( ps ax | grep /usr/bin/nautilus )

  • 1
    I don't think your echo command will kill nautilus. Also, there's pgrep nautilus and even killall nautilus etc for lazy typists like me...
    – Zanna
    Commented Oct 27, 2021 at 15:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .