5

I have installed VMware Player 4.0.2 under Ubuntu 12.04 (Final) and, apart from having to patch the modules, everything went smoothly. However, there's an irritating behavior when toggling full screen mode: toggling full screen (using Virtual Machine > Toggle Full Screen or Ctrl + Alt + Return), minimizing the player and maximizing it again changes the resolution of the guest to some strange one and the player gets "nested" between GNOME3's taskbar as every other of Ubuntu's native windows. To switch to full screen again I have to Ctrl + Alt + Return twice. Can anyone please tell me if this is the normal, expected behavior? Is there any way of "correcting" it?

The host operating system is Ubuntu 12.04 (Final) and the guest is Windows 7 (both 64 bits).

  • 1
    I am using VBox on Ubuntu 12.04. It works very well, no problems. Installed windows on it. Easy to install guest additions. Can get full screen mode, copy/paste, mounted my Linux file system to windows as g:\ drive. no problem. if VMware gives you problems, you could give VBox a try. – Nasser May 1 '12 at 8:34
  • 1
    Did you try upgrading to VMware Player 6.0? I have Windows XP, Windows 7 as well as Windows 8 on Ubuntu 12.04 and 14.04 each 64-bit with no such issues. – jobin Apr 3 '14 at 15:32
  • There is an option of choosing whose display settings to use in vmware player in prefernces -> display you can check to see if it works for you customising it – Raghvendra Singh Aug 25 '14 at 8:38
1

In WMWare Workstation you can select if you want to fit the guest to the window or the window to the guest in Edit -> Preferences.

I guess this setting should be there for the Player as well and it would be at least a workaround for your issue if you just disable both or play around with it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.