1

I have done a lot of trial and error with a ton of google searching, even tried adding the absolutle path value and doing this as root, I want to download a youtube playlist. It works stand alone as a bash script via the terminal but I would like this to run in the background

Terminal Commands

 #!/bin/bash
 youtube-dl --download-archive downloaded.txt --no-post-overwrites -ciwx --ignore-errors -- 
 extract-audio --yes-playlist --audio-format mp3 -o "/mnt/C6E0EE36E0EE2BFD/to sort/youtube- 
 dl/%(title)s.%(ext)s" 'https://www.youtube.com/watch?v=o- 
 EQb0WSQMM&list=PLBttCtrPECg7LkJ7YnirXY72UWfNn-dIb'

crontab

PATH=/bin:/usr/bin:/my/path/bin
06 17 * * * /usr/local/bin/youtube-dl --download-archive downloaded.txt --no- 
post-overwrites -ciwx --ignore-errors --extract-audio --yes-playlist --audio-format mp3 -o 
"/mnt/C6E0EE36E0EE2BFD/to sort/youtube-dl/%(title)s.%(ext)s" 'https://www.youtube.com/watch? 
v=o-EQb0WSQMM&list=PLBttCtrPECg7LkJ7YnirXY72UWfNn-dIb'

edit: Output from terminal when scheduling with crontab, works if I execute the script through the file manager

[youtube:playlist] PLBttCtrPECg7LkJ7YnirXY72UWfNn-dIb: Downloading 
webpage
[download] Downloading playlist: PLBttCtrPECg7LkJ7YnirXY72UWfNn-dIb
[youtube:playlist] playlist PLBttCtrPECg7LkJ7YnirXY72UWfNn-dIb: 
Downloading 0 videos
[download] Finished downloading playlist: 
PLBttCtrPECg7LkJ7YnirXY72UWfNn-dIb

Driving me a bit mental, thanks for your help

5
  • Do you mean it's not running at all? Or it's throwing an error? Nov 12, 2020 at 5:36
  • It's in the update, it doesn't throw errors it just won't download the playlist, bit it will it I run the commands through terminal Nov 12, 2020 at 18:50
  • Have you tried placing the command in a script and running the script with cron, preferably as your user. Have you checked the permissions of the location being written to?
    – PonJar
    Nov 13, 2020 at 9:23
  • i've tried everything, I just made a script on the computer I want to do it on and I just let it continuously loop and sleep for 5 minutes, used another computer that was running to just do it all in a continous loop via ssh Nov 14, 2020 at 9:51
  • 2 years later, and I'm having the exact same experience with 'yt-dlp'... it just won't work from the commandline Jul 22, 2022 at 14:39

0

You must log in to answer this question.

Browse other questions tagged .