11

For those of you bothered by the deluge of annoying popups asking to authenticate pretty much every move one makes in Focal Fossa ("System policy prevents this and that" when mucking about in WiFi Settings, "Authentication needed to refresh system repositories" etc.), a partial answer is here: https://c-nergy.be/blog/?p=14051.

Apparently this is due to manually installing the xRDP package in Ubuntu.

Now, if only someone could post the fix for getting rid of network and WiFi-related "Authorization Required" messages, that'd be swell! I am guessing it'd have to be another .pkla file in /etc/polkit-1/localauthority/50-local.d

3 Answers 3

14

It would not be recommended to change your network setting while connected through xRDP. If something goes wrong, you will loose your xrdp connection and you will need to logon locally to check your settings.

In practice, yes, you could create a pkla file (under /etc/polkit-1/localauthority/50-local-d) and populate it with the following info...

[Allow Wifi Scan]
Identity=unix-user:*
Action=org.freedesktop.NetworkManager.wifi.scan;org.freedesktop.NetworkManager.enable-disable-wifi;org.freedesktop.NetworkManager.settings.modify.own;org.freedesktop.NetworkManager.settings.modify.system;org.freedesktop.NetworkManager.network-control
ResultAny=yes
ResultInactive=yes
ResultActive=yes

As you can see, the pkla file does a little bit more than authorizing Wifi Scans...Please adapt as required

Hope this help Till next time See ya

4
  • 3
    I created a file scan.pkla under above mentioned directory and the message disapeared. Thank you Griffon Aug 7, 2021 at 13:12
  • thx -- also for scan disable purposes - is enough org.freedesktop.NetworkManager.wifi.scan
    – Bruno
    Apr 9, 2023 at 1:41
  • When using x2go to connect, this other related pkla goes hand in hand: unix.stackexchange.com/questions/417906/…
    – poleguy
    Jun 14, 2023 at 16:27
  • thanks, working on bookworm os
    – toouur
    Apr 16 at 21:16
0

If you're experiencing issues with authorization messages for WiFi and network settings in a remote desktop environment, a script I developed might help. PolkitFullAccessSetup.sh automates the creation of Polkit rules, granting full access to specified users or groups. This can effectively bypass the authorization messages you're encountering.

Here’s how it works:

  1. The script asks for a username and an optional group name.
  2. It creates a Polkit rule granting full access to these specified entities.
  3. The changes are applied, and the Polkit service is restarted.

Find the script and detailed instructions at: https://github.com/GabrielRamirez/Raspbian-Remote-Polkit-FullAccess

Note: This script grants extensive permissions and should be used with caution. It's more suitable for controlled environments and not recommended for general use on production systems.

Hope this helps!

0

Ensure that your user account is a member of the necessary groups to access WiFi features. The primary group is usually netdev.

You can add your user to this group using the following command: sudo usermod -aG netdev $USER

After adding your user to the group, log out and log back in or restart your system for the changes to take effect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .