1

I have installed chrony and trying to fetch time from configured NTP pool. And I have enabled NTP on timedatectl. But how can I make sure the time that I am seeing on "date/timedatectl" command is obtained from NTP servers. On Ubuntu 18.04 timedatectl command is not showing NTP synchronization details.

/etc/chrony/chrony.conf

pool time.google.com prefer iburst
keyfile /etc/chrony/chrony.keys
commandkey 1
driftfile /var/lib/chrony/chrony.drift
log tracking measurements statistics
logdir /var/log/chrony
maxupdateskew 100.0
dumponexit
dumpdir /var/lib/chrony
dumpdir /var/lib/chrony
logchange 0.5
hwclockfile /etc/adjtime
rtcsync
root@server-2:~# systemctl status chronyd
● chrony.service - chrony, an NTP client/server
   Loaded: loaded (/lib/systemd/system/chrony.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2020-11-11 12:16:13 IST; 43min ago
     Docs: man:chronyd(8)
           man:chronyc(1)
           man:chrony.conf(5)
  Process: 6228 ExecStartPost=/usr/lib/chrony/chrony-helper update-daemon (code=exited, status=0/SUCCESS)
  Process: 6202 ExecStart=/usr/lib/systemd/scripts/chronyd-starter.sh $DAEMON_OPTS (code=exited, status=0/SUCCESS)
 Main PID: 6226 (chronyd)
    Tasks: 1 (limit: 2318)
   CGroup: /system.slice/chrony.service
           └─6226 /usr/sbin/chronyd

Nov 11 12:16:13 server-2 systemd[1]: Starting chrony, an NTP client/server...
Nov 11 12:16:13 server-2 chronyd[6226]: chronyd version 3.2 starting (+CMDMON +NTP +REFCLOCK +RTC +PRIVDROP +SCFILTER +SECHASH 
Nov 11 12:16:13 server-2 chronyd[6226]: commandkey directive is no longer supported
Nov 11 12:16:13 server-2 chronyd[6226]: Frequency -88.224 +/- 0.493 ppm read from /var/lib/chrony/chrony.drift
Nov 11 12:16:13 server-2 systemd[1]: Started chrony, an NTP client/server.
sudo timedatectl set-ntp true
root@server-2:~# timedatectl 
                      Local time: Wed 2020-11-11 13:04:58 IST
                  Universal time: Wed 2020-11-11 07:34:58 UTC
                        RTC time: Wed 2020-11-11 07:34:58
                       Time zone: Asia/Kolkata (IST, +0530)
       System clock synchronized: yes
systemd-timesyncd.service active: yes
                 RTC in local TZ: no
root@server-2:~# 

No details of NTP synchronization is provided on timedatectl output. So how can we confirm if ntp is enabled and timedatectl is in sync with NTP servers.

0

To see current status of chrony's efforts to synchronise the clock, start with chronyc -n tracking and chronyc -n sources.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.