When I had windows 7 installed on my computer, My TV tuner card used to work fine after installing the drivers but on Ubuntu it is not working. I have tried several Softwares to get it working but none helped. Today I installed Me TV and when I open it, I get an error saying:

There are no DVB devices available

What can I do to get my Philips TV Tuner card working. I have a PCI card and here is the output of lspi command:

04:00.0 Multimedia controller: Philips Semiconductors SAA7130 Video Broadcast Decoder (rev 01)
  • Can you perhaps add more detail on the exact model? lspci in a terminal should be enough to get the information. – Jorge Castro Nov 12 '10 at 20:52
  • You can try installing the package linux-firmware-nonfree, this will install some drivers. If it does not work please post the output of lsusb if you have a usb card or lspci for a pci card, to get the excat device name. – david Nov 12 '10 at 21:01
  • 1
    I added the output of lspci command, I think the last line says about the TV Tuner cause I have a Philips TV Tuner card. – Gaurav Butola Nov 12 '10 at 21:11
  • This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, then please flag explaining that (as well as editing your question with any details you have). – jrg Jan 26 '12 at 1:35


I used to have a Kworld Xpert TV PVR7134 with the SAA7134-based tvtuner You will need to find card and tuner numbers , for my card it was card=63 tuner=56. I had to add these options to /etc/modprobe.d/saa7134 with echo "options saa7134 card=63 tuner=56" > /etc/modprobe.d/saa7134

More to read:

  • I didn't understand what do I do now, could you please extend you answer and show some instructions. – Gaurav Butola Nov 13 '10 at 13:11

Try installing linux-firmware-nonfree.

It has historically held a lot of drivers for TV cards and usb sticks.

  • Still getting the error "There are no DVB devices available" – Gaurav Butola Nov 12 '10 at 21:28
  • You'll probably need to restart to have it detected (if this does add the right driver). – Oli Nov 12 '10 at 21:36
  • I did restart but, still not working. – Gaurav Butola Nov 13 '10 at 12:43

At first you have to tell the make and model of the card, then you need to create a modprobe.conf file in the /etc folder manually, then run the command:

gksu nautilus

in the terminal and browse to the /etc folder, create an empty file, name it modprobe.conf then paste the following code:

# sets tv card for both analogue and digital
options saa7134 tuner=39 card=116 gbuffers=4

The numbers after tuner= and card= are variable according to your model.

For more documentation look here.

Then save the file, close the folder and restart, than install 'Tvtime' from the software centre but don't open it and run the following command first on the terminal:


after completing the above scan open Tvtime from the Sound & Video menu

Not the answer you're looking for? Browse other questions tagged or ask your own question.