My laptop (the only PC left in my home to install Ubuntu 12.04 now that it's out) is not booting from Live CD or USB. I get past the screen with the little person in the circle. but right after that, just black screen with the white cursor or indicator at top left. It just keeps blinking for hours.

What should I do?

The CD is the same that I used for the other PCs; they took it fine. I made the Live USB in Ubuntu 12.04 using the startup disk creator and the Live CD with the Windows 7 iso burning software that is preinstalled.

Here are my computer's specs: core 2 duo, 4gb ram, 320gb hdd, nvidia gt 120m, 720p monitor, dvd-rom.

  • I doubt that it matters, but just for the sake of asking, are you using ubuntu-12.04-desktop-i386.iso or ubuntu-12.04-desktop-amd64.iso? May 2, 2012 at 20:50
  • i tried with both. same thing. even 11.04 has same result. 10.04 works though!
    – Alex
    May 2, 2012 at 23:50
  • Possible answer here: askubuntu.com/questions/141311/…
    – user71536
    Jun 18, 2012 at 18:30

3 Answers 3


If you have not tried it yet, you could attempt booting using different options you can enable from the Ubuntu CD/USB Boot Options Page.

The Live CD/USB Boot Options page is usually not seen when a Live CD/USB is booted. To display it you have to trigger it by pressing any key when the small logo Ubuntu Live CD/USB 'small logo' appears at the bottom of the screen. The Live CD/USB should stop booting and display the Advanced Boot Options menu shown below.

Ubuntu Live CD/USB Advanced Boot Options menu

The main thing this page appears to provide is an easy way to allow you to boot with common kernel options applied. You press the F6 key and use the space bar to select/unselect the option(s) you want to apply and then resume the boot. 3 kernel options selected with F6

(By the way, have you already tried booting with the nomodeset kernel option? It seems to be a popular recommendation whenever video may be the problem.)

The F1 Help key displays a (nested) list of function keys showing the Live CD/USB version, boot methods, special boot parameters, and (dated?) hardware help information. I think it is mostly useful as a way to verify the release number and build date of the Live CD/USB you are booting. (It would be nice if it also mentioned whether it was 32-bit or 64-bit. Oh, well.)

Since I am not that familiar with the various options, I'll stop here and just suggest you read the Ubuntu online help to learn more about them. (I would only be parroting what it says there.)

Reply to Comment @ 2012-05-03 05:21:43Z

So what I think you are saying is that when you used the example kernel options above, noapic, nolapic, and nomodeset then you were able to boot and successfully install Ubuntu. But when you try to boot the new install it proceeds to the "the dotted boot loading screen" but then "the screen stays purple. and sits there". Correct?

If so you probably just need to boot with (some of) the same kernel options used when you installed.

This is a two step process. First you test the various combinations of the kernel options to find out the minimum required. Second, you update your default GRUB configuration so that the needed kernel options are used in the future.

I'm sure there are lots of questions that cover this, such as this one:
How do I add a kernel boot parameter?

It looks like a good answer, but I think there is a small error in it. So I am going to copy and "enhance" the first half here. You can get the second part, how to add the kernel options permanently by changing /etc/default/grub, from the original.

How To Temporarily Add a Kernel Boot Option to GRUB (based on this answer)

  1. Assume we want to add the kernel option nomodeset. (I use this as an example because it may be the only kernel option you need.)
  2. Start your system and wait for the GRUB menu.
    Note: If you don't see a GRUB menu, press and hold the Shift key right after starting the system.
  3. Select the kernel you intend to boot and press the e key to edit its GRUB boot commands. You should see a list of commands like those in the example below.
    setparams 'Ubuntu, with Linux 3.2.0-24-generic'
    gfxmode $linux_gfx_mode
    insmod gzio
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set=root bc6f8146-1523-46a6-8b6a-64b8\
    linux /boot/vmlinuz-3.2.0-24-generic root=UUID=bc6f8146-1523-46a6-8b\
    6a-64b819ccf2b7 ro  quiet splash
    initrd /boot/initrd.img-3.2.0-24-generic
  4. Change the second line from the bottom which ends with ro quiet splash.
    Additional kernel option(s) are added at the end of this line. To add nomodeset change
    6a-64b819ccf2b7 ro quiet splash to
    6a-64b819ccf2b7 ro quiet splash nomodeset
  5. Now press either Ctrl+x or F10 to boot. The change will be used, but only for this boot. It is not permanent.

I think that's it. Hope it helps!

If you're still following this, could you please post a status update of some kind. (I'm curious.)

If you find you must use the kernel boot parameter/option acpi=off, then you might also want to take a look at this answer for some suggestions on how to attempt to isolate the problem area and possibly file a bug report.

  • i tried with both. same thing. even 11.04 has same result. 10.04 works though! (i didnt know if you got the heads up on the comment with same content above.)
    – Alex
    May 2, 2012 at 23:53
  • "unknown keyword in configuration file: gfxboot. vesamenu.c32: not a COM32r image" thats from the ubuntu startup disk creator program. the cd doesnt do that.
    – Alex
    May 3, 2012 at 0:46
  • Yes, I was notified for all three of your comments. Possibly because I have posted an answer to this question, I think I will be notified of any updates to any part of the question. For (a small bit) more on how comment notifications work, see this: Replying in comments May 3, 2012 at 2:36
  • I am not following you on where unknown keyword in configuration file: gfxboot. vesamenu.c32: not a COM32r image came from. Are you saying there were errors during the creation of the media you attempted to install from? Please update your question (not a comment) with the extra/new info as recommended in the faq. May 3, 2012 at 2:42
  • Well the boot worked with the boot options in the little pic. i installed ubuntu with no other OS's. (no dual booting) now after the dotted boot loading screen, the screen stays purple. and sits there.
    – Alex
    May 3, 2012 at 5:21

If you can't boot without acpi = off and nolapic, that means that the ACPI on your computer is not supported by Ubuntu.

A bonus if 10.04 worked! Before Ubuntu 10.04 it had the driver to support the ACPI. They removed the driver from 10.10 and beyond.

Since you said that there are no other operating systems, you can disable the new card (BIOS) or disable ACPI (also from the BIOS). Use the second option if you can't find the New Card Interface.

Don't try this on a Windows computer, though. This might wreck Windows but it won't do any harm to Ubuntu.

Good Luck!

Edit: By the way, you don't have to reinstall Ubuntu after disabling the ACPI (If you didn't remove it.)

  • i know, i did that already, i even gave a guy on youtube the same answer.
    – Alex
    Jun 8, 2012 at 3:16

ok I tested it on another machine and it seems like my machine was too old. it was a Pentium 2/ 450mhz. Desktop requirements are min 700mhz. So Alex, check and see what machine specs your using and if it can handle it because it might not.

  • core 2 due, 4gb ram, 320gb hdd, nvidia gt 120m. 720p monitor. dvd-rom
    – Alex
    May 1, 2012 at 19:24
  • yeah, I guess a core 2 duo is at least as fast as a Pentium II. ;-) May 2, 2012 at 20:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .