0

after formatting my old HDD (ext4) into NTFS, this error appeared

mkntfs -Q -v -F -L "" /dev/sdb1

and

Failed to access '/dev/sdb1': No such file or directory
The device doesn't exist; did you specify it correctly?

What can I do to fix it?

edit

here s the full report, does that mean I didnt just delete one but both! partitions? I m in Ubuntu live booting from DVD right now

GParted 0.25.0 --enable-libparted-dmraid --enable-online-resize

Libparted 3.2 Delete Logical Partition (unknown, 7.88 GiB) from /dev/sdb 00:00:01 ( SUCCESS )

calibrate /dev/sdb5 00:00:00 ( SUCCESS )

path: /dev/sdb5 (partition) start: 1937002496 end: 1953523711 size: 16521216 (7.88 GiB) delete partition 00:00:01 ( SUCCESS )

======================================== Delete /dev/sdb2 (extended, 7.88 GiB) from /dev/sdb 00:00:01 ( SUCCESS )

calibrate /dev/sdb2 00:00:00 ( SUCCESS )

path: /dev/sdb2 (partition) start: 1937002494 end: 1953523711 size: 16521218 (7.88 GiB) delete partition 00:00:01 ( SUCCESS )

======================================== Delete /dev/sdb1 (ntfs, 923.63 GiB) from /dev/sdb 00:00:02 ( SUCCESS )

calibrate /dev/sdb1 00:00:00 ( SUCCESS )

path: /dev/sdb1 (partition) start: 2048 end: 1937000447 size: 1936998400 (923.63 GiB) delete partition 00:00:02 ( SUCCESS )

======================================== Create Primary Partition #1 (ntfs, 931.51 GiB) on /dev/sdb 00:00:44 ( ERROR )

create empty partition 00:00:33 ( SUCCESS )

path: /dev/sdb1 (partition) start: 2048 end: 1953523711 size: 1953521664 (931.51 GiB) clear old file system signatures in /dev/sdb1 00:00:00 ( SUCCESS )

write 512.00 KiB of zeros at byte offset 0 00:00:00 ( SUCCESS ) write 4.00 KiB of zeros at byte offset 67108864 00:00:00 ( SUCCESS ) write 4.00 KiB of zeros at byte offset 274877906944 00:00:00 ( SUCCESS ) write 512.00 KiB of zeros at byte offset 1000202567680 00:00:00 ( SUCCESS ) write 4.00 KiB of zeros at byte offset 1000203026432 00:00:00 ( SUCCESS ) write 8.00 KiB of zeros at byte offset 1000203083776 00:00:00 ( SUCCESS ) flush operating system cache of /dev/sdb 00:00:00 ( SUCCESS ) set partition type on /dev/sdb1 00:00:11 ( SUCCESS )

new partition type: ntfs create new ntfs file system 00:00:00 ( ERROR )

mkntfs -Q -v -F -L "" /dev/sdb1 00:00:00 ( ERROR )

Failed to access '/dev/sdb1': No such file or directory The device doesn't exist; did you specify it correctly?

========================================

0

Found out myself: Just do one pending action (status lower left side of GParted window) at a time, first delete all sections then create new partition.

The error is gone on two different hard drives, so I guess that was it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.