1

I'm not quite sure when it happened but a package for wine-gecko is no longer installed (I'm at Ubuntu 20.10).

This means that the Wine Internet Explorer, which uses a Gecko engine, will no longer work.

There is no error displayed on the app, but if you run it from a console the will be error messages displayed that mention the fact that Gecko is missing.

How can I resolve this issue?

1

I am using Ubuntu 20.10 also and I was getting the message:

winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path...

I tried the solution of Gustavo Carreno by downloading, extracting and copying the 32 bit package and also removing it and trying with the 64 bit package, but I was still getting the same message.

After some trials I found the solution for my case which is given in the following steps:

  $ wget http://dl.winehq.org/wine/wine-gecko/2.47.1/wine-gecko-2.47.1-x86_64.msi
  • Ran the following:
  $ wine msiexec /i wine-gecko-2.47.1-x86_64.msi 
  • The installation added the following directory underneath my home directory:
  $ ls -l /home/_myuser_/.wine/drive_c/windows/system32/gecko/2.47.1/
  wine_gecko
  • Now, Internet Explorer (when run using the wine64 iexplore.exe command) displays the web pages correctly.
1

It took some Googling but I finally was able to solve this issue:

  1. Download the *.tar.bz2 with the latest version as listed under https://wiki.winehq.org/Gecko
  2. Uncompress the contents somewhere
  3. Move the uncompressed folder to /usr/share/wine renaming it gecko
  4. To be clear on point 3: mv /path/to/umcompressed/folder /usr/share/wine/gecko

I've also read some pages that say that when you create a new prefix wine asks if you want to download gecko (and maybe mono, not sure), but I've added prefixes manually and with winetricks and never got asked to download wine-gecko.

EDIT

I've now realized that this worked on a machine that had wine installed since Ubuntu 19.04 or older but not with a fresh install of Ubuntu 20.10.

I'm still baffled at how this even worked in that one machine.

The answer provided by @FedonKadifeli is the accurate way to do it.

That is:

  1. Download the *.msi files from https://wiki.winehq.org/Gecko
  2. Run wine msiexec /i wine-gecko-{version}-{arch}.msi
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.