0

I am trying to copy music files from my Ubuntu system disk (resides in my home "Music" directory) to a USB stick.I have tried multiple different USB ports attached to different USB controllers with mulitple 3 different File Manager programs. I can successfully move single files 3 times before it hangs on the fourth, Both the File Manager program and the file copy hang.

When I try copying multiple files it hangs almost immediately. I also tried to do it through the Terminal using line commands. It also hangs on a multiple copy. I can't terminate the File Manager programs even though I try to force a termination. It won't accept the termination, it just hanging.

The only way to get out of it is to reboot the system and that takes quite a while as the system still knows a copy was going on.

Anyone have any suggestions?
USB ports used - USB 2, USB 3.1 (tried both)
USB - VFAT format, brand - CoreMicro, 29GB stick with 10GB free
System disks are RAID1, 250GB SSDs, 227GB - 130GB free
O/S Ubuntu 20.04

I have 6GB of memory and the files I am moving range from about 5MB to 12MB each

It should be noted that I can move these files to a mountable SSD disk with no issues.

Also, when I was running Ubuntu 18.04, I did not have this issue. I read about a similar issue on 18.04 and the solution was to add 2 lines to rc.local file which were:

echo $((16*1024*1024)) > /proc/sys/vm/dirty_background_bytes  
echo $((48*1024*1024)) > /proc/sys/vm/dirty_bytes  

This did not resolve my issue.

The suggestion to investigate slow transfer rate came up with some interesting information. One article indicated that one should run journalctl --follow and then plug in the USB stick.

Some errors did show up as follows:

sd 9:0:0:0: [sdh] No Caching mode page found  
sd 9:0:0:0: [sdh] Assuming drive cache: write through  

I suspect this may be an indication of the problem I am having. I need to figure out how to implement caching mode for my USB devices which I think that might resolve my problem.

Stupid me....it was the USB device that was the issue. I tried a different USB device and copy works great. Problem (me embarrased) solved!

2
  • How much memory do you have, and how big (total) are the files you move when things go bad? Search this site for "slow" "copy" and see problems others have had when system buffers fill up.
    – ubfan1
    Nov 9 '20 at 0:49
  • @ubfan1 Responded to your questions in edit of question. Thanks for trying to assist. Nov 9 '20 at 3:12
0

Issue was a faulty USB device (weird failure). Replaced the USB stick with another one and all is working fine. @ubfan1 thanks for your assistance

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.