2

Please excuse any errors in the text below. I am typing on a separate machine with an internet connection. I am attempting to install Ubuntu on an old Dell laptop and everything seems to be working well except the wifi, which obviously is pretty essential. This laptop ONLY has wifi so I cannot use any solution that requires an internet connection from the OS in question.

In "Additional Drivers" my wifi card is identified, and says:

This device is using an alternate driver.
Using Broadcom 802.11 Linux STA wireless source from bcmwl-kernel-souce (proprietary)

So it seems like it is correctly detecting the wifi card and connecting to a usable driver.

HOWEVER, when I run

sudo lshw -C network

I get:

*-network UNCLAIMED
 description: Network Controller
 product: BCM43142 802.11b/g/n
 vendor: Broadcom Inc. and subsidiaries
 physical id: 0

etc. (I can include the additional lines here if relevant)

My understanding is that "UNCLAIMED" indicates that the driver is not present. But it is present according to the software updater. How do I resolve this? I am using the latest Ubuntu.

4
  • 1
    What result from terminal for mokutil --sb-state
    – Jeremy31
    Commented Nov 8, 2020 at 11:36
  • "So it seems like it is correctly detecting the wifi card and connecting to a usable driver." How did you install that driver? It IS 3rd party and looks like the wrong one. You don't have ethernet on this machine? "old" tends to have ethernet as a connector. Those always work to connect to the web ;)
    – Rinzwind
    Commented Nov 8, 2020 at 16:27
  • mokutil --sb-state returns SecureBoot enabled
    – lastDINO
    Commented Nov 8, 2020 at 17:20
  • As I mentioned, this one only has wifi - it has an i3, so it's not ancient but it was state of the art at the time - about a decade old. IIRC at that time there was a big push for "netbook" PCs to compete with the coming Chromebooks that were supposed to disrupt the industry lol.
    – lastDINO
    Commented Nov 8, 2020 at 17:25

1 Answer 1

2

You have the incorrect driver installed for the BCM43142 wireless device.

Since you don't have a current available Internet connection, you'll have to get the required broadcom-sta-dkms, and its dependencies, on another computer, and place the files on a USB flash drive, and bring them over to this computer to install.

You'll also need to download dkms and wireless-tools from the same source.

https://packages.ubuntu.com/search?keywords=broadcom-sta-dkms&searchon=names&suite=all&section=all

https://packages.ubuntu.com/search?keywords=dkms&searchon=names&suite=all&section=all

https://packages.ubuntu.com/search?keywords=wireless-tools&searchon=names&suite=all&section=all

You need to uninstall bcmwl-kernel-souce.

sudo apt-get purge bcmwl-kernel-source

And install broadcom-sta-dkms.

sudo dpkg -i /path/to/dkms*.deb

sudo dpkg -i /path/to/wireless-tools*.deb

sudo dpkg -i /path/to/broadcom-sta-dkms*.deb

reboot

Note: If all of this presents a problem, the best way to solve it is to purchase a $10-$12 "USB to ethernet adapter", and install that way. See https://www.amazon.com/gp/product/B00YUU3KC6/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1.

1
  • This worked like a charm. Thanks!
    – lastDINO
    Commented Nov 8, 2020 at 17:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .