0

After upgrading my system from Ubuntu 18.04 to 20.04, I had some graphical glitches and had to reinstall xorg (following this answer). Everything seemed to work fine, except that I could not launch Steam anymore. I tried reinstalling Steam, including removing all the Steam related folders in /home, but to no avail. First time booting Steam after reinstall, a window with a progress bar pops up stating that "Pins potentially out of date ... rebuilding" and then nothing. All other times, there is no graphical feedback whatsoever.

The terminal output at first glance does not seem to point towards any missing packages or anything either, so I am out of ideas. Most of the related reports I find online turn out to be related to proprietary graphics drivers of dedicated GPU's (typically NVidia), but I only have an integrated Intel chipset and want to play some indie games

Running Steam on ubuntu 20.04 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Can't find 'steam-runtime-check-requirements', continuing anyway
/home/nicolas/.local/share/Steam/ubuntu12_32/steam
[2020-11-07 13:26:07] Startup - updater built Jul 28 2020 22:37:33
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
Installing breakpad exception handler for appid(steam)/version(0)
free(): invalid pointer
No minidump written, nothing to upload.
/home/nicolas/.local/share/Steam/steam.sh: regel 750: 19858 Afgebroken              (geheugendump gemaakt) $STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"
5
  • It is just a shot in the dark. ubuntu12_32 smells like a 32bit binary. maybe you need the 32bit libraries and they got removed with the update? You could try to use ldd on this binary and see which libraries it uses and check if they are present. Do ldd <full path to binary>
    – s1mmel
    Nov 16, 2020 at 7:02
  • Where is this /home/nicolas/.local/share/Steam/steam.sh from? I have this not on my system. rename the folder $HOME/.local/share/Steam
    – nobody
    Nov 19, 2020 at 18:02
  • @nobody I already tried renaming all the folders several times, Steam just keeps rebuilding them on first run
    – Bib-lost
    Nov 19, 2020 at 18:09
  • apt-cache policy steam
    – nobody
    Nov 19, 2020 at 18:11
  • Maybe you need to sudo dpkg --add-architecture i386, then update drivers sudo ubuntu-drivers install, or remove cache mv ~/.cache ~/.cache_backup. Nov 19, 2020 at 19:23

1 Answer 1

1

So, I came from an older install of Ubuntu and kept Unity desktop. I tried literally every answer that I could find on stack and on ubuntu forums, to no avail-- Finally, I installed gnome and logged into a gnome session and guess what STEAM STARTS. I haven't tested if gnome being present or being logged into gnome makes the difference. My guess is that steam client expects gnome on 20.04

1
  • Weird! Glad to hear you found a solution. Unfortunately I am no longer able to test this solution; I lost patience and reinstalled Ubuntu 20.04 from scratch.
    – Bib-lost
    Dec 23, 2020 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.