I don't know what happened. I was trying to back up my system - ironically - and now the SSD won't boot.

It isn't corrupt, it just won't boot.

I can boot from a USB stick and can mount the drive. The directories are there, so it isn't the data is gone.

I now don't have a working machine. I am using it booting via the USB. So no history, no book marks, etc. So it is difficult to go back and show exactly what happened/I did.

What I see is/was indicative of a grub fault. (From results on searches and the replies implying that this would work.) I have read and tried fixing the GRUB. Alas that doesn't seem to be the problem.

On boot, I see the spinning circle for 20.10. The screen blanks, then the spinning circle returns. Then the screen goes black and I have/see a cursor top left of the screen.

Pressing Ctl Alt F3 I can get up a terminal. But then I am stuck.

(Something else I've tried)

I know there is an option to "repair" a messed up install. I start the install and there is an option to repair the install mentioned.

Alas when I get to that page, it is ghosted out. Yet, the third option says it will install Ubuntu 20.10 beside Ubuntu 20.10. I was reluctant to try this, but did start it. But a couple of screens later it is telling me that partition resizing is about to happen. The SSD is a 500GB. I know it has a small partition and a main one. So I am not understanding what it happening and so haven't done that.

  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Zanna
    Nov 8, 2020 at 9:09
  • After 4 weeks of research, I have now got the SSD back up and working. Nov 26, 2020 at 5:11


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.