I used the "Upgrade" option to install 12.04 LTS on a laptop from 11.10.

The installation completed and after rebooting I have these issues:

  • login screen displays but all icons are missing
  • mouse/trackpad does not work at all
  • I can log in
  • after logging in the desktop is black
  • no icons appear in the left sidebar
  • all icons are missing in the desktop
  • pressing the "Windows" key brings up the dash home
  • search is working
  • can search for 'terminal' which brings up a terminal window
  • terminal window is unresponsive and I can't type any commands there
  • CTRL-ALT-F2 causes a black screen to be shown
  • an external mouse or keyboard, or an external monitor does not connect
  • restarting with no external devices connected makes no difference

The computer has a switchable intel graphics card. The other card is nvidia.

What can I do to recover from this?


Using a new copy of Ubuntu 12.04 LTS Desktop from a bootable USB drive the laptop is running correctly with none of the above issues.

Thanks all for the tips.

  • I had a similar issue trying to do the same upgrade and I didn't get error messages at all. I solved it by deleting ~/.config/compiz-1/compizconfig/. I had some customization in compiz... maybe that was it.
    – Alexandre
    May 1, 2012 at 1:27
  • I had a similar issue, I ended up deleting all the ~/.config/compiz*.
    – slm
    Aug 27, 2012 at 2:04

3 Answers 3


I suspect that if your touchpad does not work and plugging a mouse is useless, and above all, you cannot enter commands in the terminal, your only viable option is to get a Live CD (perhaps with Ubuntu 11.10, now that 12.04 seems to be so incompatible with your hardware) and reinstall Ubuntu.

While you're at it, don't forget to backup your important data. When you enter the live session, you will have the option to copy your files elsewhere.

It would even be helpful if you could copy the system logs in

  • /var/log/
    • lightdm
    • upstart
    • dist-upgrade
    • apt
  • ~/.xsession-errors

If there is important information in these, you should report bugs so your issues get addressed when possible.

After you have saved your data, just install Ubuntu as you normally would.

Let this answer be your last resort.


Have you tried recovery mode? When GRUB appears (after turning the computer on) select recovery mode from the list. (if grub does not show press ESC when the purple screen appears).

If you manage to use the terminal (in recovery mode), try to remove the nvidia driver:

sudo apt-get purge nvidia-common

Also, if you have a computer with NVidia Optimus, try to install bumblebee:

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update && sudo apt-get install bumblebee bumblebee-nvidia

I have a computer with Nvidia too. When I instaltitleled 12.04 it will start up but on sign in, the screen either goes black or shows the background with no Unity / Dash controls. To resolve this I restarted and then selected 2D mode. Now it works fine. I would prefer the 3D mode but it will not work. I think it is an issue with COMPIZ because If I Right Click on the screen and get the Change Desktop Background to bring up system settings, NONE of the windows have a title bar or control box. This has been a COMPIZ issue in the past. Anyway, try 2D mode and I believe it may work for you too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.