6

Has anyone had any luck getting the Shure MV7 USB Mic working with Ubuntu Linux?

I use Ubuntu as my primary computer, which I use a microphone for conference calls and tech podcasts on Linux. I currently use a RODE NT-USB for this purpose on Linux, but the NT-USB picks up a lot of ambient noise (since it's a condenser). When the Shure MV7 USB microphone came out, it was compelling to me because it's a high-quality dynamic USB microphone, that was touted to be able to cut out a lot of background noise. So I bought it.

However, I've been trying to use it with Ubuntu 20.04 (using the USB input) but have not been able to get it to work yet. I've also tried on another Ubuntu 16.04 system with the same results.

When I plug the Mic into the USB interface, it does show up as an available sound device in the settings. Unfortunately, the Mic reboots (alternating green and yellow lights on the device) every time I try to select the input device in the sound settings input dropdown, and then it becomes deselected after the mic reboot. Sometimes, I am able to get the selection to "stick", but no sound seems to be registered on the mic input.

This Microphone can be customized with a bit of software called Motive to configure some of the sound systems, but my understanding is that all of the settings are stored on the Mic itself (so you can use it on a computer without the software installed). While I fully expect that the Motiv software will not work on Linux, my hope is that since the settings are stored on the Mic itself, I was hoping that Linux would just detect it as a USB sound device. The mic also supposedly works on Android (which is Linux-based), IOS, and PS4, so I'd think that it would be using a pretty standard sound interface. I'm using firmware 1.1.0 on the MV7. My computer is a Dell Precision 7740.

Other USB mics (RODE NT-USB and a Logitech USB webcam/microphone) works perfectly on the same system, so I know the Linux sound system is working just fine. I'm really disappointed that the MV7 does not seem to work on Linux, where I've never had any issues with other sound devices.

I'm wondering what others have experienced with this Mic? Do you have any recommendations to get the MV7 to be usable by Linux?

arecord -l

**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC289 Analog [ALC289 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: MV7 [Shure MV7], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
3
  • 2
    I am facing the same issue, I was able to test the mic on my Android phone, but not on my Linux desktop.
    – wallnuss
    Nov 9 '20 at 18:23
  • 1
    I collected a few bits of information here github.com/alsa-project/alsa-lib/issues/98
    – wallnuss
    Nov 9 '20 at 21:18
  • 1
    Thank you @wallnuss for opening that ticket
    – Joe J
    Feb 24 at 0:18
4

Pulseaudio seems to be interrogating the MV7 in a way that causes it to reset. As a test, try to pulseaudio --kill and then plug the MV7 in (while making sure that pulseaudio has not launched from any other sources) If you can manage switch the configuration within pavucontrol/Pulse Audio Volume Control so that it uses the profile "Multichannel Input" or "Mono Input", it should come up without going into the restart loop and let you use just about all of the mic's functions. The headphone monitor within the mic will still work, however, you will just not be able to send audio from other sources up into the mic.

5
  • Would the same issues be present for those who use pipewire? (with pipewire-pulse)
    – erb
    Apr 28 at 11:29
  • 3
    Yes, I have been using the MV7 successfully with PipeWire (since 0.3.14 through 0.3.26 and counting). The most consistent factor so far with the mic "not working in Linux" is where the mic plugs into the USB bus; if I plug the device in anywhere other than directly into a root_hub, I will see usb_set_interface failed (-19)/(-32)/(-71) through dmesg and the mic will not work.You may have some success with trying various usbcore.quirks in your kernel params, such as usbcore.quirks=14ED:1012:g.
    – Alex
    May 3 at 11:45
  • @erb using pipewire with pipewire-pulse did the trick for me. No more mic reboots.
    – Gordon
    May 12 at 17:28
  • Here just to say that PipeWire solved the issue for me as well. Works like a charm so far. May 14 at 22:15
  • Thanks a lot, it helped! One addition, though: if you want to record audio through JACK (for example, in Reaper), you can do this even with audio output via MV7, you just need to select it in the output.
    – rominf
    Aug 7 at 21:17
0

First, the MV7 worked fine on my desktop pc using Ubuntu (18.04).

After I re-plugged some USB devices, I had similar issues: connecting/disconnecting loop with the message:

1:1: usb_set_interface failed (-71)

Although the (USB) webcam and video streams were stuttering. I reverted the replugging and everything was fine again: The "fix" for me is, using a USB2 and NOT a USB3 slot for the MV7.

Looks like the USB3 issue is not only related to the MV7: https://askubuntu.com/a/1199300.

2
  • That askubuntu question you linked to mentions USB 2 as the culprit, but you are saying USB 2 is the only one that works. Seems conflicting.
    – Victor
    Apr 10 at 22:24
  • Hi Victor, I (tried) to link the answer of "Mike Trest", where he is saying, that using 1.x/2.x ports was fixing his issues too.
    – Some0ne
    Apr 13 at 12:15
0

I got it working just fine on pop!_os (21.04) with pipewire instead of pulseaudio

the instruction to replace pulseaudio with pipewire is here https://www.reddit.com/r/pop_os/comments/ofdalv/replaced_pulseaudio_with_pipewire_on_popos_2104_i/h4c5p6u/

After that, it just works after plugging in.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.