0

I am using Ubuntu 20.10. My system language is Esperanto but I use the German keyboard layout and type Esperanto letters using a "dead" key (circumflex). I don't have an Esperanto keyboard configured.

Starting a few weeks ago my keyboard layout switches to the Esperanto layout in a seemingly random way. When I click on the keyboard menu it still shows the German layout as active, and when I click on "show keyboard layout" the German layout is displayed. But typing produces the characters from the Esperanto layout. For instance the key next to RETURN produces a backslash, while in the German layout it should produce a pound/number sign.

I cannot say if this happens truly randomly or by an involuntary action from myself. But it happens many times per day.

I have now added the German (Switzerland) keyboard, and switching to this and back to German (Germany) restores the German layout. But I would still prefer to understand what is happening and how I can avoid it.

Thanks, Gunnar Hjalmarsson, here is my /etc/default/keyboard:

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="epo"
XKBVARIANT=""
XKBOPTIONS=""
BACKSPACE="guess"

The "epo" layout is, of course, suspicious, maybe I should try to change it to "deu". But under settings / region and language I have no epo keyboard configured, just German (Germany), German (Switzerland), English (US) and Greek. I could remove the last two, which I never use.

When I log in the keyboard layout is set to German, so if the XKBLAYOUT is at fault it is not effective immediately.

refo@sanchopansa09:

0

1 Answer 1

1

"epo" is probably there since you selected "Esperanto" as the language when you installed Ubuntu.

It's easiest to change it manually. Open the file for editing

gedit admin:///etc/default/keyboard

and replace "epo" with "de". Then save and reboot.

2
  • Thanks again, Gunnar Hjalmarsson; since "epo" uses a three-letter language code I had assumed that German would use "deu", which gave me a busy and a bit frustrating week. Re-reading your answer I found that you proposed the two-letter code "de". It seems to have done the job. The strange thing is that I had never had the problem in many years.
    – Renardo
    Nov 16, 2020 at 17:35
  • @Renardo: Good that you figured it out. Note that keyboard layouts typically are denoted by country codes, not language codes. So English (US) is us, not en. (Esperanto is a special case, since it doesn't have a natural home country.) Nov 16, 2020 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.