1

I cannot pair my microbit with my computer to transfer files from the makecode site. I also tried with https://python.microbit.org/v/2.0 without success. The microbit shows up in my file system, and it is mounted, because I can access the Details.txt file in it. There I read that the Firmware is 0249, which is the version required so I should not need to upgrade it.

I am using Chrome version 86 on Xubuntu 16.04.

From troubleshoot in the WebUSB API, from this link precisely

https://support.microbit.org/support/solutions/articles/19000105428-webusb-troubleshooting

I followed these instructions in the terminal:

getent group plugdev >/dev/null || sudo groupadd -r plugdev

cd /etc/udev/rules.d/

sudo usermod -a -G plugdev

sudo udevadm control --reload-rules

Did not get errors nor messages so I don't know if these commands had effect in Xubuntu as they were meant for Fedora, so probably not. Anyway the microbit is still not pairing after logout login.

Should I upgrade the Firmware? Should I try Bluetooth? Should I go Windoz :) ? Thanks for your attention, I hope somebody can help me out.

4
  • FYI: Xubuntu 16.04 LTS being a flavor of Ubuntu had only 3 years of supported life (fridge.ubuntu.com/2019/03/01/ubuntu-16-04-6-lts-released) which ended 2019-April. Ubuntu 16.04 LTS Server (no desktop) or Desktop (Unity 7) have 5 years of supported life and are still supported. Refer release notes, or use ubuntu-support-status or your own system to confirm this is the case. I suggest you move to a supported release of Xubuntu for security reasons, unless you're off-line or are aware of risks. Also note Xubuntu is a desktop release, so it's 16.04, as yy releases are snap only.
    – guiverc
    Nov 1, 2020 at 11:22
  • Thank you for your information. What I get when I type ubuntu-support-status is: You have 117 packages (4.0%) supported until Abril 2021 (Community - 5y) You have 1931 packages (65.9%) supported until Abril 2021 (Canonical - 5y) You have 106 packages (3.6%) that can not/no-longer be downloaded You have 774 packages (26.4%) that are unsupported Nov 2, 2020 at 14:37
  • So that means I have a version that is still supported? or not? Anyway this has probably something to do with the microbit not pairing, I guess. You suggest me to upgrade and try again, correct? (Off topic: how can I type a new line in the comment without pressing [enter] ? ) Nov 2, 2020 at 14:48
  • 65.9% are the packages used on your base system, in common with main Ubuntu (desktop), which come with 5 years of support. Flavors have only 3 years of support, the 774 packages (26.4%) are mostly Xubuntu/XFCE packages that are no longer supported; ie. no security fixes etc. Currently the oldest Xubuntu still supported is 18.04 (it reaches the end of it's 3 years next April). It's your choice what you do with that information, if off-line its not a concern, if you're aware of the risks okay. Your 'main' Ubuntu base still receives packages, just not your desktop/gui (packages from 'universe')
    – guiverc
    Nov 2, 2020 at 20:41

0

You must log in to answer this question.

Browse other questions tagged .