After upgrading from Kubuntu 20.04 to Kubuntu 20.10, I could not login as it just showed a black screen after boot. So I switched to command line and reinstalled Kubuntu desktop with sudo apt-get install --reinstall kubuntu-desktop kde-*. After that, i was able to login and can use all applications but the icons and background of input boxes of system apps have turned black as shown below

enter image description here

Notice the black squares at the bottom right in the system tray, they used to be icons for Volume, Network, Bluetooth, etc. I can however click them and they behave as they used to. Also the desktop apps' icons are black.

enter image description here

Notice the input fields at the right of Layout, Wallpaer type and also the button backgrounds of the window.

After looking at some logs I noticed that Akonadi server was not starting up because of an unknown MySQL error and installed MariaDb as i read somewhere that it might help. Now I can start Akonadi server with akonadictl manually but still the same issue. I restarted plasma with kquitapp5 plasmashell && kstart5 plasmashell but still same issue. Also Akonadi does not start automatically when session begins.

  • I have the same issue with the recent Debian/testing upgrade to "KDE 5.19" where suddenly all icons/images seems to be black only. I wonder this could somehow being linked to rendering the SVG(?) alpha(?) channel wrongly. What graphics card are you using (on my end: Mesa Intel HD 5500)? As Debian's transition to Qt 5.15 may not be fully there yet, I also tried this article, however, the result did not change.
    – su-ca
    Commented Nov 9, 2020 at 8:33
  • I encountered this on upgrade to jammy. May be this bug(?) still not fixed.
    – mkm65535
    Commented Apr 27, 2022 at 22:19

3 Answers 3


Found the solution here, as per the link in the link:

Replacing libqt5quick5-gles with libqt5quick5 solved my problem

so make a: sudo apt install libqt5quick5 it worked for me on debian

  • I reinstalled so can't check if it works. Thanks for your answer.
    – lovesh
    Commented Nov 10, 2020 at 16:17
  • You'll need to restart the computer afterwards. Commented Sep 22, 2022 at 21:02

I encountered the same problem on Debian bullseye after a full-upgrade. The solution as pointed out by LuisF was to remove libqt5quick5-gles and then install libqt5quick5.

sudo service sddm stop
sudo apt remove libqt5quick5-gles
sudo apt install libqt5quick5
sudo service sddm start
  • worked in Kubuntu after upgrading from 20.10 to 21.04 (plasma 5.19 to 5.20), though I would only remove libqt5quick5-gles and install libqt5quick5, since stopping sddm freeze the system Commented Feb 6, 2021 at 23:33
  • Stopping sddm is just killing the display manager. You can switch to a different terminal with, for example, ctrl+alt+F2, and then log in and finish the job on the command line. Once you start sddm back up, the desktop will appear again. Commented Apr 26, 2021 at 23:56
  • This works for me. Thank you. (I was uninstalled libllvm-12 on ubuntu 20.04 caused KDE problem)
    – HaxtraZ
    Commented Jun 23, 2022 at 12:03

The solution is to install libqt5quick5, as given in other answers, regardless of whether libqt5quick5-gles was installed or not. Removing it, if it exists, is still necessary, because they conflict with each other.

On a failed upgrade from 20.10 to 21.04, I had the same symptoms, and the system couldn't automatically fix it. Installing libqt5quick5 with an sddm restart fixed it without a reboot.

  • 1
    On my system the gles-version was automatically removed when I installed the non-gles-version. So it might not be necessary to manually remove anything.
    – Mrokii
    Commented May 15, 2021 at 20:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .