0

I'm using an EPSON printer connected via USB. It's setting up successfully, accepting jobs, and instantly marking jobs as completed. But the printer isn't printing them (or showing any indication of receiving a job).

I've tried the following things:

  1. Installing it with open-source drivers
  2. Installing it with proprietary drivers
  3. Using different USB ports (2.0 and 3.0)
  4. Connecting it via Ethernet (didn't work, I also don't use WiFi so that's not an option)
  5. Restarting jobs in the queue
  6. All the steps under "USB printer" here show the printer is connected properly: https://wiki.ubuntu.com/DebuggingPrintingProblems
  7. Printing on Windows with a different device (which works fine)

I've also tried the other DebuggingPrintingProblems wiki troubleshooting steps, but can't because I don't know how to retrieve the ID of the printer's queue.

Does anyone have any ideas?

Environment

  • Printer: Epson Stylus NX635
  • OS: Ubuntu 20.04.1 LTS
  • GUI: GNOME 3.36.3 with Regolith WM
7
1

Looks like the solution was simple. For some reason you need to install the following package according to this answer:

sudo apt install printer-driver-escpr

After that, you can go through the "Add printer" wizard in the printer settings, and it will install the correct drivers. Before this, whatever drivers it was installing didn't work.

1

The Epson Stylus NX635 is an AirPrint device, so driverless printing is possible with a USB connection after purging ippusbxd.

  • Switch the device off and disconnect from USB.
  • Go to this website and install ipp-usb.
  • Switch device on and reconnect to USB.
  • Execute driverless. The output is a URI.
  • Execute lpadmin -p nx635 -v "URI" -E -m everywhere. URI is what you got in the previous step.
  • Test printing with lp -d nx635 /etc/nsswitch.conf and report back.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.