1

I currently use a USB wifi dongle, the Archer T2U: https://www.tp-link.com/us/home-networking/usb-adapter/archer-t2u/v3/. This wifi dongle has two bands, a 2.4Ghz band and a 5Ghz band. I can confirm that both bands work, since I have also used it on my Windows partition where the 5Ghz band does work with my 5Ghz wifi signal.

But I have the problem that on Ubuntu 20.04 the wifi dongle does not seem to be willing to connect to my 5Ghz wifi signal. All connections, 2.4Ghz and 5Ghz connections, show up in the wifi selection screen but when I try to connect to the 5Ghz connection, with the proper password, it loads for a long time and gives me this error: Activation of network connection failed. It does connect to my 2.4Ghz wifi signal. I have not installed any drivers for this device, it worked when I plugged it in. I have been searching but I can't seem to find any information on this specific issue. Furthermore, sometimes when I start up my Ubuntu partition the wifi dongle is not even recognized by the system. I cannot select the wifi settings in the system settings, although the wifi dongle is detected when I run lsusb in my terminal. The output of this command I have added below:

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 045e:02fe Microsoft Corp. XBOX ACC
Bus 003 Device 002: ID 1b1c:1b20 Corsair Corsair STRAFE RGB Gaming Keyboard
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1038:1260 SteelSeries ApS SteelSeries Arctis 7
Bus 001 Device 002: ID 2357:011f TP-Link 802.11ac WLAN Adapter 
Bus 001 Device 004: ID 046d:c539 Logitech, Inc. USB Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I used this question: My wireless/WiFi connection does not work. What information is needed to diagnose the issue? to gather information about my wireless and have added it in a pastebin: https://paste.ubuntu.com/p/VCGZYxbpP4/

TL:DR My Archer T2U cannot connect to a 5Ghz wifi network on Ubuntu, but can connect to it on my Windows partition. Sometimes, the wifi setting does not show in my system settings upon startup even though the device is recognized when running lsusb.

1

Seems I have found the repair. I went browsing around about other people who may have this issue and ran into this website: https://linux-hardware.org/index.php?id=usb:2357-011f.

On this website it shows what ID requires what kind of drivers for full functionality. The ID of my device is 2357-011f, and apparently it requires the following driver: https://github.com/aircrack-ng/rtl8812au.

So yeah, install that driver and everything worked for me!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.