2

I have installed Ubuntu 20.04 on a new PC and originally managed to get the RTL8125 NIC driver working by installing the Realtek driver. However after an update it has stopped working and I am unable to get it working again.

The output of sudo lshw -C network is:

*-network UNCLAIMED

   description: Ethernet controller
   product: RTL8125 2.5GbE Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:06:00.0
   version: 05
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list
   configuration: latency=0
   resources: ioport:f000(size=256) memory:fcd00000-fcd0ffff memory:fcd10000-fcd13fff

The output from lspci -knn | grep Eth -A3 is:

06:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller [10ec:8125] (rev 05)
    DeviceName: RTL8111E Giga LAN
    Subsystem: Gigabyte Technology Co., Ltd RTL8125 2.5GbE Controller [1458:e000]
    Kernel modules: r8169

I have downloaded the driver from the realtek website at https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software

and followed the instructions in the README file. However when I run the command sudo ./autorun.sh I get the error:

Check old driver and unload it.
Build the module and install
make[3]: *** No rule to make target 'information'. Stop.
make[2]: *** [Makefile:340: __build_one_by_one] Error 2
make[1]: *** [Makefile:167: clean] Error 2
make: *** [Makefile:48: clean] Error 2

I am fairly new to Linux so I don't understand what this error means, so any help would be much appreciated

1
  • Most likely you rin the command from a wrong directory. – Pilot6 Oct 29 '20 at 12:46
0

In my case the r8168 didn't work with the Gigabyte B550 Aorus Elite motherboard. So what I did was:

I also downloaded the driver from the realtek website at https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software but I had to connect my mobile phone via usb and share the internet connection with the desktop in order to download the 2.5G Ethernet LINUX driver r8125 for kernel up to 5.6

From a Terminal window run:

sudo apt install r8168-dkms (this package was needed in order to run the r8125-90004.01 diver script with no errors)

cd /home/username/Downloads

cd r8125-90004.01

sudo chmod +x autorun.sh

sudo ./autorun.sh

sudo reboot

Please keep in mind that, after a kernel update a re-install of the RTL8125 is nedeed. So it's a good ideia to keep the folder r8125-90004.01 in Downloads.

2
  • r8168-dkms is unrelated. You needed dkms. – Pilot6 Nov 8 '20 at 17:49
  • Thanks very much, this worked for me – modicum Dec 6 '20 at 2:54
1

I have now resolved the issue.

In the end I downloaded the “GBE Ethernet LINUX driver r8168 for kernel up to 5.6” driver from the Realtek website, instead of the 2.5GB driver and running the ./autorun.sh command as root worked.

1
  • 3
    Then please accept your answer, not the incorrect one. – Pilot6 Dec 28 '20 at 14:22
0

I ran into the same problem you described above.

If you have a fresh install of Ubuntu, the build essentials ar not installed. And because build essentials is an meta-package, you could not download it and put it manualy per usb to ubuntu. But you need this package to build network-kernel-driver, especially you want to install uefi-supported driver.

It is a mess, but it is possible to manage this.

I have selected all packages in the meta-package "build essential" put it in one folder together with the source-code of the network device. Then first I install all packages in this selected folder with command dpkg -i *.deb. If dpkg can not resolve dependiencies, then verify wich package is not installed , because of wrong installation order, then install missed package with dpkg -i {package-name}.deb and then repeat "dpkg -i *.deb", until all dependiencies are resolved.

then run the ./autostart.sh in the source-code.

All is fine, now.

ubuntu20_04withB550 lspci connectedlan

One little hint: If you work with an Nvidia-Graphics-device 1080 Ti, do not use the Nouveau driver included in repository. Use closed source nvidia drivers from NVIDIA to get all functionalities.

Greetz

If you want more information which .deb-packages you need, go to www.pc-service-puls.de and get kontakt information.

2
  • <Linux device driver for Realtek Ethernet controllers> This is the Linux device driver released for RealTek RTL8125 2.5Gigabit Ethernet controllers with PCI-Express interface. <Requirements> - Kernel source tree (supported Linux kernel 2.6.x and 2.4.x) - For linux kernel 2.4.x, this driver supports 2.4.20 and latter. - Compiler/binutils for kernel compilation – crackerwilli Mar 21 at 20:56
  • I use r8125-9.005.01, too – crackerwilli Mar 21 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.