I used to dual boot Windows 10 and Lubuntu. I mostly use Lubuntu and rarely use Windows 10, so now I just want to use Linux. so I deleted the partition from windows 10 and wanted to change it to /home partition. but an error occurred. I'm using KDE Partition Manager to do this.

this is the error code

Create a new partition (120.89 GiB, ext4) on ‘/dev/sda’ Job: Create new partition on device ‘/dev/sda’ Command: sfdisk --force --append /dev/sda

Failed to add partition ‘New Partition’ to device ‘/dev/sda’.

Failed to add partition ‘New Partition’ to device ‘/dev/sda’. Create new partition on device ‘/dev/sda’: Error Create a new partition (120.89 GiB, ext4) on ‘/dev/sda’: Error

There is also something that I think is strange because Windows 10 still appears as a boot option even though I have deleted the partition where Windows 10 is located

boot menu

and this is proof that I have deleted partitions from windows 10

drive information

1 Answer 1


Did you delete the partition on sda first and attempt to create the new partition in "unassigned space" ? Did you run the tool (gparted?) with sudo rights? Try gparted and not KDE partition manager.

The grub bootloader creates the bootmenu. You'll have to look into changing grub and reassigning the points (ie: windows won't start, but this is just a reference to where windows would start from).

  • don't mind me, I just restarted it again and it worked. god dammit.
    – Alif Irhas
    Oct 29, 2020 at 14:21
  • bootloader menu and partitions are independent. As for sfdisk error, it's harder to tell without more info but at least it worked after reboot. Oct 30, 2020 at 16:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .