1

After the upgrade from Ubuntu 18.04 to 20.04, the network manager icon no longer works. When I click on it everything except for VPN connections is greyed out. I got the network up and running configuring netplan directly but it was nice to have the ability to use the icon, quicker and more flexible.

I reinstalled network manager but to no avail, same problem. I cannot get it to work. Has this been replaced in the new version and if yes, is there something I can install to replace it other than always having to go into netplan to reconfigure my network card.

**This is a desktop installation. Please note, I had to change the YAML configuration for renderer from network manager to networkd to get it to work.

Output of yaml file

network:
  renderer: NetworkManager
*# This file describes the network interfaces available on your system
*# For more information, see netplan(5).
network:
  version: 2
  renderer: NetworkManager
*# Let NetworkManager manage all devices on this system
network:
  version: 2
  renderer: networkd
  ethernets:
    enp3s0:
      addresses: 
        -  192.168.1.10/24
      gateway4: 192.168.1.254
      nameservers: 
        search: [mydomain,otherdomain]
        addresses: [75.153.176.1, 8.8.8.8]

Output of Interfaces

(Interfaces)
*# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Output of lshow network

*-network                 
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 03
       serial: 48:5b:39:7c:e2:d3
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom 

ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd
> 1000bt 1000bt-fd autonegotiation
>            configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl_nic/rtl8168d-2.fw
> ip=192.168.1.10 latency=0 link=yes multicast=yes port=MII
> speed=1Gbit/s
>            resources: irq:18 ioport:e800(size=256) memory:fdfff000-fdffffff memory:fdff8000-fdffbfff
> memory:febf0000-febfffff

@heynnema - Thanks for your response. I initially tried your suggestions a while back and also after the upgrade, that was the default configuration. Nevertheless, I attempted to do the exact steps you suggested. The results are identical, no LAN connection and greyed out options under the network icon.
In response to question of how many yaml files I may have, please see the following:

/etc/netplan file listing

ls -l /etc/netplan
-rw-r--r-- 1 root root 36 Oct 30 11:11 00-default-nm-renderer.yaml
-rw-r--r-- 1 root root 36 Oct 27 16:02 00-default-nm-renderer.yaml.old
-rw-r--r-- 1 root root 159 Oct 27 15:55 01-netcfg.yaml.old
-rw-r--r-- 1 root root 104 Oct 30 10:51 01-network-manager-all.yaml.exp
-rw-r--r-- 1 root root 300 Oct 13 21:20 01-network-manager-all.yaml.netd
-rw-r--r-- 1 root root 104 Oct 13 23:37 01-network-manager-all.yaml_netman
-rw-r--r-- 1 root root 104 Oct 30 11:08 01-network-manager.yaml

Contents of 01-network-manager.yaml

cat 01-network-manager.yaml
#Let NetworkManager manage all devices on this system network:
version: 2
renderer: NetworkManager

Also tried same config in a file named 01-network-manager-all.yam

Same result - no Lan connection and greyed out Ethernet network options under network icon

uname -r

5.4.0-52-generic

Revised yaml file (the only file now in netplan)

cat 01-network-manager.yaml

network:
version: 2
renderer: NetworkManager

Same issue, network icon has ethernet network greyed out and LAN not connected. I did remove all files but one however, the system keeps adding in a default yaml file called "00-default-nm-renderer.yaml". When I revert back to networkd control (specified IP address assigned in yaml file) LAN connects with no issues.

cat 00-default-nm-renderer.yaml

network:
renderer: NetworkManager

/etc/cloud/cloud.cfg.d/99-disable-network-config.cfg does not exist. in fact, there is no etc/cloud directory

ls -al /etc/netplan

total 24
drwxr-xr-x 2 root root 4096 Oct 30 16:21 .
drwxr-xr-x 184 root root 12288 Oct 29 16:05 ..
-rw-r--r-- 1 root root 36 Oct 30 15:29 00-default-nm-renderer.yaml
-rw-r--r-- 1 root root 300 Oct 30 15:40 01-network-manager.yaml

I just used the default yaml file and it failed the same way, however, it did work at the initial login as my userid login was initializing and then LAN stopped working. I know it worked for a little bit as some apps I start up on initialization that need the LAN connection worked but after initialization completed and I then tried to access the Internet through my browser it failed and I then noticed all my LAN access was no longer working and ip addr didn't see my LAN connection (no IP address)...weird?
Just to be clear though, the icon never ungreyed (if that is a word?)
I don't have a 20.04 CD but I will create one and give your suggestion a try once I get one created.

Booted from a fresh USB version of Ubuntu 20.04. The network icon was quite different and the output was different but it worked.

17
  • Is this a Desktop or Server installation? Edit your question and show me cat /etc/netplan/*.yaml and cat /etc/network/interfaces and sudo lshw -C network.
    – heynnema
    Oct 29, 2020 at 16:31
  • When you respond to a request for more info, make sure to let the requester know that you've done so, by starting a new comment with @heynnema (example for me)... that will notify the requester.
    – heynnema
    Oct 29, 2020 at 23:15
  • @heynnema - Thanks for trying to assist me. Tried your suggestions and posted my results. Oct 30, 2020 at 18:42
  • You didn't follow my instructions. /etc/netplan still has multiple .yaml (and other) files. The .yaml that you do show is incorrect, and is not a copy of what's in my answer. Please follow my exact instructions. Report back.
    – heynnema
    Oct 30, 2020 at 19:53
  • Show me uname -r.
    – heynnema
    Oct 30, 2020 at 20:00

2 Answers 2

0

It's a little unclear from your updates, whether you have ONE /etc/netplan .yaml file, or THREE /etc/netplan .yaml files.

Never mind, delete all of them and replace it with ONE .yaml file, called 01-networkmanager.yaml, that contains just this:

Note: Make sure to keep the indentation and spacing just as you see it, and no tabs.

network:
  version: 2
  renderer: NetworkManager

Then:

sudo netplan generate

sudo netplan apply

reboot

Then:

Use the NetworkManager GUI settings to configure your wired ethernet connection.

Update #1:

We reinstalled Ubuntu.

0

Resolved:
Had to reinstall 20.04. Now all is working as it should. Sledgehammer instead of an easy fix. Thanks to @heynnema for sticking with me to the end.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.