10

When starting Thunderbird in Ubuntu 20.10 an error message is displayed

XML Parsing Error: undefined entity
Location: chrome://messenger/content/messenger.xhtml
Line Number 905, Column 3:
  <key id="openLightningKey"
--^

and nothing more happens. However Thunderbird can be started in "safe mode" with the command line command

thunderbird -safe-mode

I have a number of language packs installed, German, English (CA), English (GB), French and Swedish.

How can I make Thunderbird start OK from the apllications menu?

1
  • 1
    Did you install any dictionaries/language packs by any chance?
    – Kay
    Oct 28, 2020 at 17:07

4 Answers 4

5

I was experiencing the same problem just earlier after installing an official language pack by Mozilla. After closing and restarting Thunderbird, I was shown a popup with the exact same message you posted, and couldn't get Thunderbird running again.

Based on messages in this (German language) forum thread: https://www.thunderbird-mail.de/forum/thread/85658-thunderbird-startet-nicht-bzw-gibt-fehlermeldung-nur-im-safemode-m%C3%B6glich/?postID=468615, others are having the same problem, also after having recently installed or updated language packs.

I managed to solve the problem on my end by moving the offending file (langpack-en-GB@thunderbird.mozilla.org.xpi, in my case) out of Thunderbird's extensions directory. On my system, all my Thunderbird settings, including the exensions directory, reside at /home/MYUSER/.thunderbird/RANDOMSTRING.default.

2
  • This helped, thank you. In my case it was langpack-nl@.... After removing this file, I would expect the interface to be in English, but it still presents Dutch.
    – Jos
    Oct 29, 2020 at 16:46
  • Nice catch, fixed it on my side using mv langpack-fr@thunderbird.mozilla.org.xpi ../ in the following directory: /home/user/.thunderbird/8rz2sdbv.default/extensions
    – egdavid
    Nov 2, 2020 at 14:21
1

I managed to work around this issue on Ubuntu 20.10 by starting with thunderbird --safe-mode and removing all language packs (menu "Add-ons" -> "Languages"). Note that on my system I wasn't able to remove all of them since some of them were installed from Debian packages. Turns out the latter weren't causing any problems, though, and I was able to start Thunderbird without safe-mode.

In case you want to remove the language packs installed from Debian packages as well you can do so by running (adjust according to the languages installed on your machine):

$ apt purge thunderbird-locale-de thunderbird-locale-en

After doing so the list of language packs should be empty and you should be able to start Thunderbird normally.

1
  • This worked for me! (Ubuntu 20.10) Especially the first part: open thunderbird in safe mode and disable the language packages. Restart without safemode Nov 12, 2020 at 20:55
1

The accepted answer did not helped me but this did:

  1. start thunderbird in the command line/shell/terminal with thunderbird --safe-mode
  2. choose "disable all add-ons" and
  3. click the button "Make changes and restart". Then it can be started as usual like using the the normal thunderbird start icons or thunderbird in the command line/shell/terminal.

Maybe this is a more elegant solution for users that do not want or can move files in the configuration directories.

0

In particular in fedora 31 with TB 78.3.1 (64-bit), I went to /home/MYUSER/.thunderbird/RANDOMSTRING.default/extensions and did following (which eliminated the problem).

% mkdir suspect
% mv langpack-en* suspect
1
  • Your answer seems to be a duplicate of my original solution.
    – Kay
    Oct 31, 2020 at 9:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.