1

USB ports stopped working after I booted my laptop and have not worked even after doing several reboots. Nothing is being detected but it charges my phone with a usb cord. I am new to Linux in general.

HP 15 Notebook Product Number: G1V01UA#ABA

Output of lsusb:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I'm not sure what to do as my pendrive gets warm when connected but my pc does not recognize it.

3
  • Hey Reuben Prosper! What do you exactly mean by "stopped working"? Are you able to connect any pendrive and see its files? Open terminal, paste this: lsusb and press Enter. Copy the output and paste it in your question (not in the comments). – Random Person Nov 2 '20 at 9:31
  • Please mention the laptop name and model number in the question. Also, does the computer recognise the pendrive? Is the issue with one port or both the ports? – Random Person Nov 2 '20 at 15:02
  • @technastic_tc Also had same problem on desktop. Ran update. Rebooted. Suddenly lsusb says I have USB drives -- but when plug in to them nothing happens. Of note keyboard doesn't work. Switched ports. Tried reinstall xserver. No joy. Have old PS/2 keyboard typing on now. Interesting to see I'm not the only one with problems this update. – Williams Nov 11 '20 at 6:04
0

The answer seems to be:

Bug in kernel 5.4.0-44 and 0-45 so far. External keyboard or dropping down to kernel 5.4.0-42 works in recovery mode. – crip659 Sep 13 at 21:05

per: Ubuntu 20.04 - keyboard not working

In my fix attempts I'd inadvertantly deleted old kernels but can reinstall by:

sudo apt install linux-image-5.4.0-42-generic linux-headers-5.4.0-42-generic

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.