0

I got an upgrade notification to upgrade to 20.10. I tried with both the command terminal and the updater.

It starts to update but each time I get an error message. Tells me the problem is with the network connection. I have a wifi connection and I tried an Ethernet connection.

Each time I get the same error. Can someone please help me with this?

Bellow is the error message I get every time I try to upgrade

E:Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/groovy/main/binary-armhf/Packages 404 Not Found [IP: 91.189.91.38 80], E:Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/groovy-updates/main/binary-armhf/Packages 404 Not Found [IP: 91.189.91.39 80], E:Some index files failed to download. They have been ignored, or old ones used instead

1
0

That's because you can put that address in your browser to see that the source files do not exist on the internet, so it's not being maintained any more.

I have done a search for those files, and they seem to still exist at these locations, so you can try to replace the URLs in /etc/apt/sources.list with one of them:

http://18.219.209.11/ubuntu-ports/dists/groovy/main/binary-armhf/
http://52.15.97.248/ubuntu-ports/dists/groovy/main/binary-armhf/
http://212.47.225.68/ubuntu-ports/dists/groovy/main/binary-armhf/
http://91.189.94.8/ubuntu/dists/groovy/main/binary-armhf/
https://packages.microsoft.com/ubuntu/20.10/prod/dists/groovy/main/binary-armhf/

If you don't want to bother with a text editor, from the command line:

sudo sed -i s@/us.archive.ubuntu.com@/91.189.94.8@g /etc/apt/sources.list

Then

sudo apt update
sudo apt upgrade

If apt complains that they contain files that are not signed with the official keys, then your best course of action would be to create a new SD card from an updated image, and then just copy over your /home directory with an SD Card adapter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.