1

Got trouble with starting one app.

Introduction

I have Ubuntu-20.04-amd64 with core 5.x on my VDS.
I have needed to install other core with some patch. But patch was available for 4.9.158 core version.
I built the core with patch and changed grub for new core loading.

Patch was needed for special possibilities in some programm.
After this, Im trying to start my app, but something went wrong.

Trouble

/home/ejudge/solves/12345/26/in: error while loading shared libraries: /lib/x86_64-linux-gnu/libc.so.6: cannot read file data: Operation not permitted

libc.so.6 exists. I checked it.
enter image description here I ran it as root.

Updates:

Using KK's answer tried:
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/lib/x86_64-linux-gnu/libc.so.6 LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/lib/x86_64-linux-gnu/ LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/lib/x86_64-linux-gnu/libc.so LD_LIBRARY_PATH=/lib/x86_64-linux-gnu/libc.so
LD_LIBRARY_PATH=/lib/x86_64-linux-gnu/libc.so.6

But it doesn't work.
P.S.: I clear variable LD_LIBRARY_PATH after each try and ofc export it.

1 Answer 1

1

You need to define and export libc.so library path.

LD_LIBRARY_PATH=$LD_LIBRARY_PATH:<location of libc.so>
export LD_LIBRARY_PATH

Try to run application after that.

2
  • only libc.so.6?
    – icYFTL
    Oct 27, 2020 at 18:21
  • I mean LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/lib/x86_64-linux-gnu/libc.so.6 in my case
    – icYFTL
    Oct 27, 2020 at 18:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .