I have been using Viber for Desktop (the official .deb package downloaded from https://download.cdn.viber.com/cdn/desktop/Linux/viber.deb ) for at least 4 normal Ubuntu versions (18.10 through 20.04) with no problem. A few days ago I upgraded from Ubuntu 20.04 to 20.10 and now the /opt/viber/Viber executable crashes on startup with the following message on terminal:

Segmentation fault (core dumped)

System log has the following:

Oct 27 19:04:42 xxx kernel: [ 3782.065767] Viber[25573]: segfault at 0 ip 00007ff5e4804bc5 sp 00007fff2e7dc3b0 error 4 in iHD_drv_video.so[7ff5e46eb000+348000]
Oct 27 19:04:42 xxx kernel: [ 3782.065771] Code: 01 48 83 f8 42 75 e6 31 db 66 41 89 9f 58 0c 00 00 49 8b 5f 28 8b 83 f0 1d 00 00 85 c0 0f 84 ba 01 00 00 48 8b b3 e8 1d 00 00 <81> 3e 00 00 01 00 48 89 75 c8 0f 85 a3 01 00 00 44 8d 70 f0 4d 63

A crash dump on system's /var/crash directory is also generated.

I have reinstalled the latest version from Viber's website.

I have deleted the ~/.ViberPC and ~/.cache/Viber Media S.à r.l directories from the home directory, but the problem stays the same.

Any other user having the same problem?


I contacted viber.com. First, they answered by proposing a complete removal and re-install. However, this was something that I have already done. After informing them so, they requested the crash dump, which I sent to them.

Currently Viber for Ubuntu is in version 13.3.1 and has not been updated since July 2020. So, we are stuck to this version until an update is released.

For the time being, the temporary workaround is to retry starting Viber after crash, until it does not crash. It seems that the crash is pretty random, with a chance of 10% of the times Viber starting without a crash. So, I wrote the following Bash function and added it to the end of my ~/.bash_aliases file:

function vib
  while ! /usr/bin/pgrep -i Viber ; do
    nohup /opt/viber/Viber >/tmp/vib.out 2>/tmp/vib.err &
    sleep 3

To start Viber, I simply type vib into a terminal and wait until it starts.

Update (Oct 2021)

This problem seems to have been solved in Viber version


  • Look at the dump in /var/crash - it's a text file.
    – waltinator
    Oct 27, 2020 at 20:38
  • You are using a proprietary program that is not associated with Ubuntu. Consider contacting the developers for support.
    – xiota
    Oct 29, 2020 at 16:23
  • 1
    I did contact. I will post more information here, if or when there is a response.
    – FedKad
    Oct 29, 2020 at 16:32
  • 1
    @ТомицаКораћ No. This only happens on Ubuntu 20.10 and it does not depend to a chat that has video in it or not. Viber crashes during startup, i.e. before any window is displayed. What version of Ubuntu are you using?
    – FedKad
    Nov 13, 2020 at 9:47
  • 1
    Thank you for the suggestion of starting it until it doesn't crash :D I can confirm that this works for me too. It's silly, but oh well - at least it works(once in a while) xD Jun 8, 2021 at 15:40

5 Answers 5


It seems that segfaults happen with free intel-media-va-driver but not with intel-media-va-driver-non-free for other programs as well: https://bugs.launchpad.net/ubuntu/+source/gthumb/+bug/1903569

Try to replace the free driver like this:

apt install intel-media-va-driver-non-free
  • 1
    This worked for me, thanks!
    – panta82
    Apr 4, 2021 at 22:46
  • I've had crashed with other apps (like mplayer, which I use a lot). This has fixed all of them. Thanks for the finding!
    – user582175
    Jun 17, 2021 at 12:58
  • This worked for me too! Thank you.
    – skryvets
    Aug 14, 2021 at 20:48

I have same problem.

Strange but work for me: run viber with argument --help

cd /opt/viber
./Viber --help

And edit shortcut /usr/share/applications/viber.desktop

  • 1
    It worked once, but didn't work the second time. Neither changing the shortcut did the job
    – lefterav
    Nov 10, 2020 at 11:07
  • No. I don't think this works. I tried several times cd /opt/viber ; ./Viber --help, but it did again crash most of the times.
    – FedKad
    Nov 10, 2020 at 11:08

In /usr/share/applications/viber.desktop I got Exec=/opt/viber/Viber %u I replace it with Exec=/opt/viber/Viber and now it seems to start ok (without a crash)

  • no, still failed sometimes on start
    – Viktor
    Mar 8, 2021 at 12:24

When installed via snap viber-mtd, the application would crash like this:

$ /snap/bin/viber-mtd.viber
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
Qt: Session management error: None of the authentication protocols specified are supported
sh: 1: xdg-mime: not found
Qt WebEngine ICU data not found at /snap/viber-mtd/17/opt/viber/resources. Trying parent directory...
Qt WebEngine resources not found at /snap/viber-mtd/17/opt/viber/resources. Trying parent directory...
[31099:31099:1115/085234.003880:FATAL:credentials.cc(155)] Check failed: NamespaceUtils::DenySetgroups(). : Permission denied
#0 0x7f4f8d63111e base::debug::StackTrace::StackTrace()
#1 0x7f4f8d641bde logging::LogMessage::~LogMessage()
#2 0x7f4f8d641e99 logging::ErrnoLogMessage::~ErrnoLogMessage()
#3 0x7f4f8e333f7c sandbox::(anonymous namespace)::SetGidAndUidMaps()
#4 0x7f4f8e3345d5 sandbox::Credentials::CanCreateProcessInNewUserNS()
#5 0x7f4f8d2a4de5 content::ZygoteHostImpl::Init()
#6 0x7f4f8cf57314 content::BrowserMainLoop::EarlyInitialization()
#7 0x7f4f8cf5b190 content::BrowserMainRunnerImpl::Initialize()
#8 0x7f4f8cd60d19 QtWebEngineCore::WebEngineContext::WebEngineContext()
#9 0x7f4f8cd62135 QtWebEngineCore::WebEngineContext::current()
#10 0x7f4f8ccff931 QtWebEngineCore::BrowserContextAdapter::defaultContext()
#11 0x7f4f95018618 QQuickWebEngineProfile::defaultProfile()
#12 0x0000006ac8bf ApplicationPrivate::preRunningInitialization()
#13 0x0000006a6504 ViberApplication::start()
#14 0x00000067e25b ViberMain()
#15 0x7f4f89d05840 __libc_start_main
#16 0x0000004d7047 <unknown>

After trying a few things, I eventually discovered that the application launches successfully like this:

$ /snap/viber-mtd/current/opt/viber/Viber

Seems to be working fine now when launched this way.

  • 1
    Ok. But this is a different method of usage. But, I am using the .deb version.
    – FedKad
    Nov 15, 2020 at 16:35
  • Fair enough. The app seems to be poorly implemented and anything unexpected seems to upset it. So, perhaps trying different ways of invoking the app, as I did, will eventually find a way to avoid the landmines
    – Waxrat
    Nov 15, 2020 at 17:14
  • Ok. I will look at it. But, in my case viber runs without a problem roughly in 20% of the invocations which are executed exactly in the same way. So the problem (in my case) seems completely random!
    – FedKad
    Nov 15, 2020 at 19:18

tried everything, for me it worked with viber-unofficial snap .. There's no dark theme though, but it works at least


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .