I am trying to connect a Google Pixel 4a to a Ubuntu desktop via USB to transfer files in Music and Photos. I am not using the lead supplied by Google because it is usb c male to male, but a usb charge lead that came with a Sony phone. File transfer does work with this way on a Windows laptop but I'd rather not use someone else's machine. The phone does not appear to be mounted and does not appear if I try "lsusb".

Also there is no option on the phone available to select charge/file transfer by usb.

I have tried the suggestions for a Pixel 2 in previous questions and Android file transfer app without success. My older Sony and Samsung phones work fine. I Spoke to Google Helpdesk and they say it's not their issue contact Ubuntu Community.

Please can anybody help?

  • now dosen't work with windows either Oct 27, 2020 at 11:01

3 Answers 3


I think I've sorted it only some USB a male to usb C male leads work, by chance I tried a different lead and it works. I have several leads, but only two out of five work. Strange but true.


Yeah, I think this only works with cables that have USB 2.0 (or higher?) so USB 1 cables with a white-colored lead won't work.

If you download the KDE Connect app on your Pixel 4a and Laptop running Ubuntu you can file transfer files that way. It is basically an open-source version of the phone companion app for Windows and available on the google play store

You can search how to install KDE Connect on your version of Ubuntu if you don't know how. I know the command (sudo apt install kdeconnect) works on Ubuntu 18.04 LTS, but I'm not sure if the command is the same for other versions of Ubuntu.


This seemed to be a cable issue for me. I've certainly previously connected my Ubuntu host to my Pixel phone before.

I connected the two with a nice, sturdy USB-C cable. Seeing "File Transfer" was not an options, I rebooted both. Still no luck.

I tried flipping the USB-C cable, FWIW, no luck.

Then I tried what seems to be a USB-2 USB-C cable... that for some reason worked.

My conclusion: that original cable isn't right.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .