Possible Duplicate:
I can't boot into a usable system after updates. What should I do?

I have 11.04 (upgraded to 11.10, I think) installed along with Windows 7 64bit using wubi. I tried to upgrade to 12.04 when the update manager told me it was available. It downloaded all the packages but then hung at the very beginning of the actual update routine. I opened the terminal from the update manager and hitting enter a couple of times got the process started again. After an hour or so (maybe more), the last line on the terminal read something like "process halted, too many errors" and there was a restart button present. I restarted and got a login screen that was barely functional. When I did log in I got a blue screen only. Ctrl-Alt-Del closed that login session but there were only a couple of broken icons at the top right of the screen. I did a hard reset and have not tried to log in to Ubuntu again. If I download the 12.04 iso, will it wipe out the broken upgrade?

marked as duplicate by fossfreedom May 26 '12 at 7:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


I had the same problem with my login and when looking into it saw that dpkg was corrupt - after trying the steps from this article I had better luck: http://ubuntuforums.org/showthread.php?p=8753631

I had to actually delete the offending line in /var/lib/dpkg/status that prevented dpkg from updating any packages but after that these steps worked to get me back up and running on 12.04.

sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
sudo aptitude update
sudo aptitude full-upgrade

Then make sure to restart.

Hopefully that helps you too

Not the answer you're looking for? Browse other questions tagged or ask your own question.