tried a lot of different answers people gave around the web... none of them worked I get wireless internet and all.... but whenever I tried going wired it doesn't even recognise the option of a network. got a toshiba leptop,

Ethernet adapter- Ethernet controller: Atheros Communications Inc. AR8152 v1.1 Fast Ethernet (rev c1)

running ubuntu 12.04 after I thought that upgrading from 11.10 will solve it....

tried doing

sudo ifconfig eth0 up
sudo ifconfig eth0 down


sudo ifconfig eth0 down
sudo dhclient -r eth0
sudo ifconfig eth0 up
sudo dhclient eth0

still nothing

tried going to gedit and adding the eth0 and loopback manually...

still nothing... anyone?!...

  • wired connection works on the windows I run for junk stuff needed to be done with it(like LoL or other win only games I sometime play) so the problem is one or another definition I have probably ruined with my horse playing with this os settings XD

can anyone help me?...

Edited: tried working with a cellular modem to check if that works. doesn't. looks like the eth manager isn't working. anyone ?


Have you tried going in to the Network Manager and manually setting your IP, Gateway, etc.? If you right click on the network manager icon and then select 'Edit Connections...' the window will open and you can select which connection you would like to edit. Once you get into that window go to 'IPv4 Settings' or IPv6 Settings' (depending on your network). Then you can change from Automatic(DHCP) to 'Manual', then you can put your settings in for a static IP address. That might get you up and running. Also it would be wise to look at how it is set up in Windows. If it is set to use a static IP in Windows then you may need to set it up like that in Ubuntu. That is what I would do. Check Windows and make sure the Linux side looks the same or similar. If it still doesn't work let us know.

  • TY for the quick replay.on the windows it's dhcp. it's as if the manager for the wired connection isn't there... and I don't want to manually configure it every time I go to a place where I need to go into a router that hasn't got a proper wifi... – Nimirooyn Apr 30 '12 at 20:01

This appears more like driver issue. I had similar problem on my Toshiba Satellite C640. Atheros Communications Inc. AR8152 v1.1 Fast Ethernet (rev c1) is one of the latest generation card, drivers for which does not work out-of-box. This card requires "atl1c" module which was not present when I tried "modinfo" on my Toshiba C640. There are other modules alt1, atl1e, etc.

Fortunately there is a solution. Please refer forum thread Wired Ethernet Not Detected. I have followed these steps to get my card working

  1. Download latest stable version from Compat Wireless

  2. Extract compat-wireless-*.tar.bz2 and please read README

  3. Install essentials for compiling module

     sudo apt-get install linux-headers-\`uname -r\`
     sudo apt-get install build-essential
  4. Browse to compact-driver-* folder in shell. Build & Install module using following commands (as per forum post)

    ./scripts/driver-select atl1c
    sudo make install
  5. Reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.