I decided to install Ubuntu on my laptop alongside Windows 10. I downloaded the Ubuntu 20.04 iso file from the official Ubuntu website. I formatted my USB from NTFS to FAT32 and used Rufus 3.12 to make a bootable USB drive with the Ubuntu .iso file that I had downloaded.

After getting into the BIOS I selected the boot from USB in the boot menu, but I didn't get any "Install Ubuntu" option. It seemed to me as if Ubuntu has already been installed, but it hasn't. I also tried Universal USB Installer 19.9.5 instead of Rufus, but the result was same.

This is the next screen after I chose booting from USB in the boot menu.

enter image description here

These are the errors I got after choosing the first "Ubuntu" option.

These are the errors I got after choosing the first "Ubuntu" option

Unable to find a medium containing a live file system
  • 1
    Did you disable Secure Boot in the BIOS/UEFI ?
    – Raffles
    Oct 25, 2020 at 11:39
  • Yes, but didn't help
    – hugo159
    Oct 25, 2020 at 12:18
  • What machine is it?
    – Raffles
    Oct 25, 2020 at 12:20
  • It is Asus x571gt-bq103t.
    – hugo159
    Oct 25, 2020 at 12:22
  • 2
    I turned off the Windows fast startup and it worked, thank you.
    – hugo159
    Oct 25, 2020 at 21:27

1 Answer 1


The answer in this case is

  1. to make sure that Secure Boot is disabled in the BIOS/UEFI and
  2. Disable Windows fast startup (Win 8.1 and Win 10). This is done by booting into Windows, and calling up the Settings menu and looking for "Turn on fast startup", then uncheck it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .