0

I use this printer for sometime but I rarelly need to print. Now with Ubuntu 20.04 it does not print at all. It installs the driver automatically, but when I try to print anything it does not print and in the definitions, printers, appears the message: stopped please restart when the problem is solved. I installed a windows 10 in virtualbox to check, and it prints perfectly. I tried to use the usb connect and the WIFI connection. In both ways it does not work. It worked in version 18.10... Any ideias to solve this? Thank you.enter image description here

7
  • Have a WiFi connection and give what you get for driverless. – brian_p Oct 25 '20 at 19:47
  • what do you mean? – Kaspacainoombro Oct 26 '20 at 18:45
  • What do I mean? Use the WIFI connection and type driverless in a terminal. Send the output here. – brian_p Oct 26 '20 at 19:20
  • I did not know what driverless was. It outputs this: ipp://Canon%20iP110%20series._ipp._tcp.local/ – Kaspacainoombro Oct 27 '20 at 18:21
  • I just decided to print a test page from the ubuntu printer configuration and today it worked but it took almost 3 minutes to print it. It makes long pauses while printing. Then i decied to print a page from a PDF. It immediatly appears one job in the printer but it already passed 4 minutes and still did not start printing. Igo to the active jobs of the printer and appear the job as paused! I click play and nothing happens. After 5 minutes the print auto turn off ecause it has nothing to do: so Ubuntu did not even sent any command to the printer. – Kaspacainoombro Oct 27 '20 at 18:31
1

Execute this command:

lpadmin -p ip500 -v ipp://Canon%20iP110%20series._ipp._tcp.local -E -m everywhere

Can you print if you issue the command lp -d ip500 /etc/nsswitch?

3
  • The lp command gives an error:lp: Error - unable to access "/etc/nsswitch" - File or folder does not exist. The lpadmin does not give any error neither a message. Nothing happens. – Kaspacainoombro Oct 28 '20 at 6:09
  • Sorry, I did not notest that the lpadmin installs a new printer called ip500. And I tried to print to this one and it worked perfectly even gives the status of the ink. – Kaspacainoombro Oct 28 '20 at 6:13
  • /etc/nsswitch is a common typo of mine! It should be /etc/nsswitch.conf. Sorry about that. lpadmin only gives an output when there is an error. Getting no output shows it completed successfully. – brian_p Oct 30 '20 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.