12

Ubuntu 20.04

I've tried several answers from other similar questions.

After changing from Nouveau to NVIDIA driver, I now don't have any WiFI settings (no icon in the taskbar, nothing but VPN settings in network settings, no connection).

Switching back to Nouveau doesn't fix it.

My WiFI card is Intel 6 AX200

Out put of lshw -C Network (the WiFI part):

*-network UNCLAIMED
       description: Network controller
       product: Wi-Fi 6 AX200
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 1a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0
       resources: memory:fc700000-fc703fff

Output of sudo modprobe iwlwifi:

     modprobe: ERROR: ../libkmod/libkmod-module.c:838 kmod_module_insert_module() could not find module by name='iwlwifi'
modprobe: ERROR: could not insert 'iwlwifi': Unknown symbol in module, or unknown parameter (see dmesg)

Seems the driver isn't being picked up(?) though I've manually downloaded it myself to try to fix this and moved it to /lib/firmware and rebooted.

Any ideas?

Output of dpkg -l | egrep -v '^ii|rc':

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
+++-==========================================-=====================================-============-======================================================================================================

Output of dpkg -l | grep linux:

ii  binutils-x86-64-linux-gnu                  2.34-6ubuntu1                         amd64        GNU binary utilities, for x86-64-linux-gnu target
ii  console-setup-linux                        1.194ubuntu3                          all          Linux specific part of console-setup
ii  libselinux1:amd64                          3.0-1build2                           amd64        SELinux runtime shared libraries
ii  libv4l-0:amd64                             1.18.0-2build1                        amd64        Collection of video4linux support libraries
ii  libv4lconvert0:amd64                       1.18.0-2build1                        amd64        Video4linux frame format conversion library
ii  linux-base                                 4.5ubuntu3.1                          all          Linux image base package
ii  linux-firmware                             1.187.2                               all          Firmware for Linux kernel drivers
ii  linux-generic-hwe-20.04                    5.4.0.51.54                           amd64        Complete Generic Linux kernel and headers
ii  linux-headers-5.4.0-42                     5.4.0-42.46                           all          Header files related to Linux kernel version 5.4.0
ii  linux-headers-5.4.0-42-generic             5.4.0-42.46                           amd64        Linux kernel headers for version 5.4.0 on 64 bit x86 SMP
ii  linux-headers-5.4.0-51                     5.4.0-51.56                           all          Header files related to Linux kernel version 5.4.0
ii  linux-headers-5.4.0-51-generic             5.4.0-51.56                           amd64        Linux kernel headers for version 5.4.0 on 64 bit x86 SMP
ii  linux-headers-generic-hwe-20.04            5.4.0.51.54                           amd64        Generic Linux kernel headers
ii  linux-image-5.4.0-42-generic               5.4.0-42.46                           amd64        Signed kernel image generic
ii  linux-image-5.4.0-51-generic               5.4.0-51.56                           amd64        Signed kernel image generic
ii  linux-image-5.4.0-52-generic               5.4.0-52.57                           amd64        Signed kernel image generic
ii  linux-image-generic-hwe-20.04              5.4.0.51.54                           amd64        Generic Linux kernel image
ii  linux-libc-dev:amd64                       5.4.0-51.56                           amd64        Linux Kernel Headers for development
ii  linux-modules-5.4.0-42-generic             5.4.0-42.46                           amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-modules-5.4.0-51-generic             5.4.0-51.56                           amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-modules-5.4.0-52-generic             5.4.0-52.57                           amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-modules-extra-5.4.0-42-generic       5.4.0-42.46                           amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-modules-extra-5.4.0-51-generic       5.4.0-51.56                           amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-modules-nvidia-450-5.4.0-52-generic  5.4.0-52.57                           amd64        Linux kernel nvidia modules for version 5.4.0-52
ii  linux-modules-nvidia-450-generic-hwe-20.04 5.4.0-52.57                           amd64        Extra drivers for nvidia-450 for generic-hwe-20.04
ii  linux-sound-base                           1.0.25+dfsg-0ubuntu5                  all          base package for ALSA and OSS sound systems
ii  pptp-linux                                 1.10.0-1build1                        amd64        Point-to-Point Tunneling Protocol (PPTP) Client
ii  python3-selinux                            3.0-1build2                           amd64        Python3 bindings to SELinux shared libraries
ii  syslinux                                   3:6.04~git20190206.bf6db5b4+dfsg1-2   amd64        collection of bootloaders (DOS FAT and NTFS bootloader)
ii  syslinux-common                            3:6.04~git20190206.bf6db5b4+dfsg1-2   all          collection of bootloaders (common)
ii  syslinux-legacy                            2:3.63+dfsg-2ubuntu9                  amd64        Bootloader for Linux/i386 using MS-DOS floppies
ii  util-linux                                 2.34-0.1ubuntu9                       amd64        miscellaneous system utilities
7
  • The wifi issue is not related to Nvidia. Probably trying to install Nvidia drivers you broke something. /lib/firmware is not related either. Try to boot with a previous kernel. It looks like the kernel is not fully installed.
    – Pilot6
    Commented Oct 25, 2020 at 8:11
  • dkms status and dpkg -l | egrep -v '^ii|rc' please.
    – nobody
    Commented Oct 25, 2020 at 8:36
  • @Pilot6 yes, booting into an earlier kernel version, wifi works. Commented Oct 25, 2020 at 8:59
  • @nobody - the first command returns nothing. The second - added to my question Commented Oct 25, 2020 at 8:59
  • Then please add output of dpkg -l | grep linux.
    – Pilot6
    Commented Oct 25, 2020 at 9:03

3 Answers 3

14

I also faced exact missing iwlwifi issue after installing recommended nvidia drivers using sudo ubuntu-drivers autoinstall. Ubuntu was using my country ppa mirrors which probably were outdated. I fixed this issue by

  1. rebooting to old kernel version using GRUB menu (2nd option)
  2. Switching PPA to global mirrors and reinstalling nvidia drivers using same autoinstall command.
  3. Running sudo apt update && sudo apt upgrade -y to update again to latest kernel
  4. Reboot. At this point GRUB entry pointing to latest kernel should work without any issue.
5
  • 2
    This worked for me. I run sudo ubuntu-drivers autoinstall after purging nvidia drivers because I was stuck before login with the message "/dev/sda1: clean ..." as is said in the following answer: askubuntu.com/questions/882385/… The only thing I would recomend is to run apt update before ubuntu-drivers autoinstall, I don't now if it makes a difference maybe you or someone can clarify.
    – kl0z
    Commented May 23, 2022 at 17:17
  • ^This mostly worked for me, but I had to purge the previous nvidia-driver-xxx install as @kl0z said. I did this before step 2, by running purge commands from here: askubuntu.com/questions/206283/… I ran: ``` $ sudo apt purge nvidia-390 (nvidia-driver-XXX) -y $ sudo apt autoremove -y $ sudo apt autoclean ``` Commented Oct 19, 2022 at 5:06
  • UPDATE: I also had to reboot after purging the old drivers. Without the reboot between installations it didn't work. So: Purge -> reboot -> install new drivers -> reboot Commented Oct 19, 2022 at 6:04
  • Works for me too. Thank you
    – scorpion
    Commented Nov 2, 2022 at 20:45
  • ubuntu-drivers‘s autoinstall option is marked as deprecated
    – Paul
    Commented Jul 7, 2023 at 18:19
10

You need to install linux-modules-extra-5.4.0-52 by

sudo apt install linux-modules-extra-5.4.0-52-generic

It is weird that it didn't install automatically on a kernel upgrade. Probably you've interrupted an upgrade.

9
  • 2
    This might be me being very silly, but running this command doesn't work for me because the Wi-Fi driver is broken, so my device has no means of connecting to the internet.
    – Teymour
    Commented May 12, 2021 at 20:04
  • 3
    I was able to solve the problem by booting using the previous version of the kernel :D
    – Teymour
    Commented May 12, 2021 at 20:14
  • @TeymourAldridge And what did you do about not being able to upgrade to the latest kernel then? And wouldn't it try to do boot using the latest one again next time?
    – batjko
    Commented Oct 5, 2021 at 21:15
  • 1
    IIRC, using that version I was able to install the missing drivers (because I had internet) so the next time I booted, it was all fine.
    – Teymour
    Commented Oct 8, 2021 at 21:12
  • This kinda worked for me, but I did it with the linux-modules-extra-5.19.0-40-generic one, as I'm using Ubuntu 22.04.2 LTS. Commented Apr 19, 2023 at 0:33
1

I encountered this same issue in Ubuntu 22.04 when attempting to upgrade from version 525 to version 530 of my NVIDIA graphics driver. After I rebooted, there was no internet connection available.

As suggested by Abdul Rauf, I switched to an older kernel version (as noted in Abdul Rauf's answer), which let me regain internet access. sudo ubuntu-drivers autoinstall didn't work for me due to this error. In addition, using the Additional Drivers GUI to change my driver failed to work at times (and the reason wasn't always given--I sometimes just saw an X icon with no message).

However, I was able to install the driver by entering sudo apt install nvidia-driver-530 into the terminal. (You can enter ubuntu-drivers devices beforehand to see which drivers are available.) Next, I ran sudo apt update and sudo apt upgrade, which I believe successfully reinstalled the missing headers. After restarting my computer, I was able to use the 530 version of the driver on the latest kernel without losing my internet access.

I think I was using the US mirror while installing these updates, so switching to the global mirror (as suggested by Abdul) was not necessary in my case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .