2

I use default cube scene. I tried both snap installation and without an installation, running from extracted folder blender-2.90.1-linux64.tar.xz blender-2.83.8-linux64.tar.xz before ugrade to new operation system ubuntu 20.10 I was using ubuntu 20.04 and it was working now on ubuntu 20.10 other export methods works. just gltf crashes I run from terminal to get error message but I dont know how to find the "core dumped" file

:~/$ blender Read prefs: /home/u/.config/blender/2.90/config/userpref.blend /run/user/1000/snap.blender/gvfs/ non-existent directory found bundled python: /snap/blender/47/2.90/python Aborted (core dumped)

:~/Downloads/blender-2.90.1-linux64$ ./blender Read prefs: /home/u/.config/blender/2.90/config/userpref.blend found bundled python: /home/u/Downloads/blender-2.90.1-linux64/2.90/python Aborted (core dumped)

1
  • I am getting a similar issue in Ubuntu 20.10 but at program startup whenever I have certain add-ons enabled, like RetopoFlow, MeshMachine, and BoxCutter. – UrbenLegend Nov 1 '20 at 13:47
0

Okay I found a workaround for this. It seems like the snap and official Blender builds have a Python mismatch and that's what's causing Blender to crash when running or loading certain addons.

This PPA seems to have a fairly complete Blender 2.90 build that works with Ubuntu 20.10. I've tested with MeshMachine, RetopoFlow, and BoxCutter.

Make sure to install the python3-numpy package, as quite a few addons depend on it.

0

this crash is caused by a bug in Python 3.7.7 which ships with Blender, see our findings here: https://developer.blender.org/T84752

As discussed in the bug report, you can either install Flatpak version or try this workaround: Open your Blender installation's directory and edit the file [blender version]/python/lib/python3.7/ctypes/__init__.py by commenting out line 273 (just add # in front of it):

#CFUNCTYPE(c_int)(lambda: None)

Save file, restart Blender and see if it works. Or just wait for a Blender update, they might fix it soon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.